Лекция 2

Лекция 1

Математические модели обобщенной ЭПС.

Для анализа наиболее общих закономерностей, характерных для ЭМС при регулировании момента, скорости и положения независимо от технической реализации реальная ЭПС, как объект управления, часто заменяется математической моделью, называемой обобщенной электромеханической системой. Математическая модель содержит те же функциональные узлы , что и реальная ЭПС. Специфика конкретных систем отражается в значении обобщенных параметров.

Расчетные схемы и уравнения механической части.

Исследования динамики показывают, что в большинстве практических случаев реальные механизмы могут быть сведены к трехмассовой, двухмассовой и одномассовой расчетным схемам.

Параметрами обобщенной трехмассовой механической системы (рис. 1.1) являются суммарные приведенные моменты инерции масс J1, J2 и J3 и эквивалентные приведенные жесткости механических упругих связей C12 и C23.

Здесь Cik = dMi / djk - жесткость связи. При абсолютно жесткой связи соответствующий коэффициент равен ¥.

Первая масса представляет собой ротор двигателя и жестко с ним связанные элементы. К этой массе приложен электромагнитный момент двигателя M и момент статической нагрузки Mc1. который обычно является суммарным моментом потерь на валу двигателя и жестко связанных с ним элементах. К промежуточной массе механизма приложен момент сопротивления Mc2 и к третьей - момент внешней нагрузки Mc3.

Трехмассовая модель при исследовании ЭМС используется в тех случаях, возникает необходимость более детального анализа условия движения масс механизма. Для решения задачи при этом обычно используется математическое моделирование на ЭВМ, поскольку аналитическое решение получается весьма громоздким.

Двухмассовая модель, упрощенно представленная на рис.1.2, наиболее удобна для изучения влияния упругости механических связей на поведение ЭМС и в данном курсе для нас будет являться основной.

Поведение двухмассовой системы можно описать следующей системой уравнений, составленных на основании второго закона Ньютона

ì J1 dw1/dt= M- M12 -Mc1 (1.1 а)

í M12=C12 (j1 - j2 ) ( 1.1 б)

î J2 dw2/dt= M12 -Mc2 (1.1 в )

Дифференцируя обе части уравнения 1.1, б, получим

ì dw1/dt= - (1/ J1) M12 +(1/ J1) M -(1/ J1) Mc1 (1.2 а)

í dM12 /dt =C12 w1 - C12 w2 (1.2 б)

î dw2/dt= (1/ J2) M12 - (1/ J2) Mc2 (1.2 в)

В тех случаях, когда параметры системы таковы, что влияние упругих связей незначительно, или при решении задач, в которых с этим влиянием можно не считаться, механическая часть представляется простейшей расчетной схемой, не учитывающей влияние упругих связей-жестким приведенным звеном. В этом случае многомассовая система заменяется одной эквивалентной массой с моментом инерции JS , на которую воздействует электромагнитный момент двигателя M и суммарный приведенный к валу двигателя момент нагрузки Mc. Последний включает в себя все внешние силы, приложенные к механической системе, кроме момента двигателя M.

Приведем двухмассовую систему 1.1 к одномассовой, предположив связь между первой и второй массами абсолютно жесткой. Отличием ее от ранее рассмотренной системы является равенство углов j1 = j2. а также M12=0. Складывая уравнения 1.1 а и 1.1б , получим

JS dw/dt= M- Mc, (1.3)

где JS = J1+J2 и Mc= Mc1 + Mc2

Уравнение 1.3 представляет собой основное уравнение движения электропривода. Его значение для анализа физических процессов в ЭМС исключительно велико. Оно правильно описывает движение механической части любой ЭМС в среднем. Поэтому с его помощью можно по известному электромагнитному моменту двигателя и значениям JS и Mc оценить среднее значение ускорения электропривода, предсказать время, за которое двигатель достигнет заданной скорости и решить многие другие практические вопросы даже в тех случаях, когда влияние упругих связей в системе существенно.

Обобщенная модель двигателя с линеаризованной механической характеристикой

Анализ электромеханических свойств двигателей различного вида показывает, что при определенных условиях механические характеристики принципиально разнотипных двигателей описываются идентичными уравнениями. Соответственно в этих границах аналогичны и основные электромеханические свойства двигателей, что создает предпосылки для обобщенного изучения динамики электромеханических систем.

Для описания электромеханических процессов в любом двигателе с линейной механической характеристикой можно использовать системы уравнений 1.2 или 1.3 в сочетании с уравнением динамической жесткости. Последнее может быть записано в виде

Tэ dM/dt = b (w0-w1) - M, (1.4)

где b= DM/Dw1 - статическая жесткость механической характеристки, Tэ-электромагнитная постоянная времени и w0 - обобщенное входное воздействие в виде скорости холостого хода двигателя. Из выражения 1.4 можно найти операторное изображение динамической жесткости в виде

M(p)/ w0(p)½при w1=0 = [image] (1.5)

и установить, что она описывается передаточной функцией апериодического звена первого порядка.

Естественно, что выражение 1.4 для различных типов двигателей отличаются значениями статической жесткости, электромагнитной постоянной времени и обобщенного входного воздействия. Особенности применяемого двигателя при этом отражаются в конкретном смысле переменных и выражениях параметров.

Например, для двигателя с независимым возбуждением ( с постоянным магнитным потоком Ф и якорным управлением коэф-фициенты обобщенного уравнения определяются следующим образом

Для асинхронного двигателя при линеаризации рабочего участка его характеристики в области s< s кр эти параметры определяются соотношениями

Аналогичные соотношения могут быть найдены и для ДПТ с полюсным управлением и для синхронного двигателя с зависимым частотным управлением (БДПТ).

Обобщенный управляемый преобразователь

Управляемый преобразователь электрической энергии при пост-роении математических моделей первого приближении можно описать дифференциальным уравнением первого порядка следующим образом

Tпр dw0/dt= Kпр uу - w0 ( 1.6)

где uу - входное управляющее воздействие (выходной сигнал регулятора в замкнутой системе; w0- выходной сигнал преобразователя; Tпр и Kпр - соответственно постоянная времени и статический коэффициент передачи преобразователя. Как видно описание преобразователя соответствует апериодическому звену первого порядка с передаточной функцией

Объединяя уравнения 1.6, 1.4 и 1.2 в систему и разрешая их относительно соответствующих производных, получим систему уравнений состояния обобщенной ЭПС с двухмассовой механической подсистемой в виде 1.7

dw0 /dt= -(1/ Tпр ) w0 +(Kпр / Tпр ) uу (1.7,а)

dM/dt = (b/ Tэ) w0- (b/ Tэ)w1 -(1/ Tэ)M, (1.7,б)

dw1/dt= - (1/ J1) M12 +(1/ J1) M -(1/ J1) Mc1 (1.7,в)

dM12 /dt =C12 w1 - C12 w2 (1.7,г )

dw2/dt= (1/ J2) M12 - (1/ J2) Mc2 (1.7, д )

Как видно, обобщенная ЭПС даже при двухмассовой механической подсистеме описывается системой дифференциальных уравне-ний 5-го порядка и доступна точному анализу лишь на ПЭВМ (на цифровой модели). Учитывая трудоемкость теоретического анализа полной системы и громоздкость аналитических выражений, описывающих электро-механичесские процессы в обобщенной ЭПС, специфику этих процессов мы выясним, проведя далее анализ этих процессов отдельно для механической подсистемы и отдельно для обобщенного двигателя.


Лекция 2

Динамические свойства звеньев обобщенной ЭПС

Рассмотрим вначале механическую подсистему обособленно от электрической части с целью изучения ее динамических свойств. Входным воздействием этой подсистемы будем считать электромагнитный момент M и задавать его независимой функцией времени. Переходные процессы в подсистеме, обусловленные изменением этого момента, называются механическими переходными процессами.

Процессы в указанной подсистеме описываются уравнениями 1.7 в,г,д.

d w1/dt= - (1/ J1) M12 +(1/ J1) M -(1/ J1) Mc1

dM12 /dt =C12 w1 - C12 w2

d w2/dt= (1/ J2) M12 - (1/ J2) Mc2

Этой системе уравнений соответствует приведенная на рис.2.1 ДСС.

Нас будут интересовать передаточные функции каналов M®w1 и M®w2. Из приведенной на рис.2.1.структурной схемы подсистемы находим

Ww2M(p)= [image] , (2.1)

где

W0= [image] - (2.2)

резонансная частота двухмассовой упругой механической системы.

Введем понятие соотношения масс g= (J1+J2)/J1. Тогда выражение для передаточнаой функции Ww1M(p) принимает вид

Ww1M(p)= [image] , (2.3)

где g= (J1+J2)/J1- коэффициент соотношения масс.

Система в соответствии с полученной передаточной функцией может быть представлена последовательным соединением интегрирующего звена, форсирующего звена второго порядка с сопрягающей частотой [image] и консервативного колебательного звена с сопрягающей частотой wс2=W0.

При g=1, полиномы в числителе и знаменателе передаточной функции сокращаются и передаточная функция системы определяется передаточной функцией идеального интегрирующего звена, т.е.

Ww1M(p)=1/ JS p

а структурная схема механизма принимает вид

Механические переходные процессы

Изменение управляющего или возмущающих воздействий вызывают в механической подсистеме переходные процессы, называемые механическими переходными процессами.

Рассматривая одномассовую систему, движение которой описывается дифференциальным уравнением первого порядка

JS d w/dt= M- Mc,

где JS = J1+J2 и Mc= Mc1 + Mc2,

легко установить, что при постоянстве статического момента сопро-тивления закон изменения скорости в переходном процессе определяется характером изменения во времени управляющего момента. Так для получения экспоненциальной кривой скорости при пуске необходимо обеспечить экспонециальную зависимость момента от времени. Для получения равномерно ускоренного изменения скорости необходимо формировать прямоугольный закон изменения момента двигателя во времени (см. рис. 2.3,а,б ).

б)

а)

t
Если известен характер изменения момента двигателя и приведенного момента нагрузки с помощью указанного уравнения можно установить характер изменения скорости не прибегая к его решению. Механическая часть, представленная в виде жесткого звена, как отмечалось, отражает движение системы в среднем и не дает точного представления о характере движения упруго связанных масс. С целью выяснения этого влияния рассмотрим реакцию на скачок момента от 0 до M в двухмассовой системе при нулевых нагрузках Mc1 и Mc2 и нулевых начальных условиях.

Найдем вначале реакцию координаты w2 , используя ранее полученную передаточную функцию (2.1). Операторное изображение интересующей нас величины при M(p)= M/p равно

w2(p)= [image] ,

где e ср=M/JS - среднее значения ускорения второй массы.

Переходя к оригиналу получим

w2(t) = e ср t -(e ср/W0) Sin W0t

График зависимости w2(t) представлен на рис.2.4.. Видно, что скорость w2 (t) в среднем меняется по линейному закону с ускорением e ср=M/JS и содержит незатухающую гармоническую составляющую с амплитудой e ср/W0 и частотой W0 .

Используя выражение для передаточной функции (2.3) найдем реакцию скорости первой массы на скачок управляющего момента в виде

w1(t) = e ср t +(e ср/W0 )(g-1) Sin W0t

Эта составляющая отмечена штриховой линией на уже рассмот-ренном рисунке. При прочих равных условиях колебания скорости w1(t) тем меньше, чем меньше J2 или чем ближе g к 1 , а увеличение W0 при тех же ускорениях снижает амплитуды колебаний как первой, так и второй массы.

ДИНАМИЧЕСКИЕ СВОЙСТВА ОБОБЩЕННОГО электродвигателя С ЛИНЕЙНОЙ МЕХАНИЧЕСКОЙ ХАРАКТЕРИСТИКОЙ

Система уравнений, описывающих указанный двигатель, известна :

Tэ dM/dt = b (w0-w1) - M,

JS dw1/dt= M- Mc

где JS = J1+J2 и Mc= Mc1 + Mc2

Вводя понятие электромеханической постоянной времени обобщенного ЭМП Tм= JS/b, перепишем эту систему в виде

dM/dt = -(1/ Tэ)M - (b/ Tэ)w1+ (b/ Tэ) w0,

d w1/dt= (1/ b Tм) M -(1/ b Tм) Mc

Этой системе соответствует приведенная на рис. 2.5 ДСС .

Полученную ДСС путем эквивалентных преобразований легко привести к виду

Рис. 2.6

Передаточные функции и частотные характеристики обобщенного ЭМП.

В системах регулирования скорости вращения интерес представляет реакция скорости w1 на управляющее воздействие w0 и на возмущение по нагрузке Mc, в системах регулирования момента - реакция на те же воздействия электромагнитного момента M. Эти реакции можно найти, зная соответствующие передаточные функции. Определим интересующие нас передаточные функции, используя структурную схему на рис.2.6.

Ww1,w0(p)=w1(p)/w0(p)= [image] (2.4)

Ww1,Mc(p)=w1(p)/Mc(p)= [image] (2.5)

WM,w0,=M(p)/ w0(p)= [image] (2.6)

WM,Mc(p)=M(p)/ Mc(p)= [image] (2.7)

Во всех случаях характеристическое уравнение обощенного двигателя имеет вид

TэTм l2 + Tм l +1=0

и , следовательно, собственные числа матрицы A или корни характе-ристического уравнения определяются выражением

Вводя обозначения

d= 1/2 Tэ и W д=Ö 1/TмTэ,

получим

l1,2= -d ±Ö d2-Wд2

Как видно, в зависимости от соотношения электрической и элек-тромеханической постоянных времени могут иметь место 3 случая :

-при d > W д оба корня уравнения вещественные, отрицательные и разные;

- при d = W д имеем пару кратных и вещественных корней l1=l2=-d

- при d < W д имеем пару комплексно- сопряженных корней вида

l1,2=-d ± jW св,

где W св=Ö Wд2-d2- частота свободных колебаний

Динамические характеристики канала w0®w1

При достаточно малых значениях Тэ, таких что 4Тэ<Тм и, следовательно d>w д , передаточная функция имеет два вещественных полюса l1 и l2 . Вводя обозначения Т1= mod (1/l1 ) и Т2= mod (1/l2 ), передаточную функцию канала (2.4) приведем к виду

Ww1,w0(p)=w1(p)/w0(p)= [image] , (2.8)

что соответствует последовательному соединению двух апериодических звеньев первого порядка с постоянными времени Т1 и Т2 причем Т1> T2 . В литературе такое звено носит название апериодического звена второго порядка. Такому звену соответствует переходная характеристика h(t) вида

h(t)= L-1{W(p)/p}= 1- [image] + [image] (2.9)

Рис.2.7

Выноска 3 (без границы): h(t)

Переходная характеристика канала для данного случая представлены на

Как видно, реакция на скачок управления скорости носит апери-одический характер и время ее определяется приближенно как 3T1. Оно растет с ростом электрической и механической постоянной времени при сохранении соотношения постоянных Тэ<4Тм

При 4Тэ=Тм характеристическое уравнение системы имеет два равных вещественных корня l1=l2=-d=-1/2 Тэ. Передаточная функция ЭМП с одномассовой нагрузкой ( 4.1) принимает при этом вид

Ww1,w0(p)=w1(p)/w0(p)= [image] , (2.10)

где Т=2Тэ, что соответствует последовательно включенным одинаковым апериодическим звеньям первого порядка. Переходная характеристика ЭМП при этом описывается выражением

h(t) = 1-(1+d t)e-dt =1-(1+t/2Tэ) e-t/2Tэ (2.11)

Как видно и в этом случае переходная характеристика носит апе-риодический характер, при этом время процесса составляет величину tп= 6 Тэ.

При 4Тэ>Тм корни характеристического уравнения ЭМП становятся комплексно-сопряженными вида l1,2=-d ± jW св,

Общее выражение передаточной функции (2.7) приобретает вид передаточной функции колебательного звена

Ww1,w0(p)=w1(p)/w0(p)= [image] , (2.12)

где постоянная времени T и коэффициент затухания x определяются выражениями

T=Ö Tэ Tм и x= Tм/ 2Ö Tэ Tм = Ö Tм/ 2 Tэ = (Ö m)/2=d/ W0

Переходная функция канала w0®w1 определяется в рассматрива-емом случае выражением

Рис.2.8.

h(t)= 1 - [image] (2.13)

На рис. 2.8 представлен ряд зависимостей h(t), соответствующих различным значениям x.

Анализ этих кривых, а также выражения для h(t) , что

а) время затухания колебаний зависит только от электрической постоянной времени Тэ и определяется как tп= 6 Тэ.

б) с ростом постоянной времени Тэ растет время переходного процесса и при этом уменьшается логарифмический декремент затухания n= 2pd/W св и возрастает частота свободных колебаний W св при неизменной электромеханической постоянной времени Тм.

в) При m=2 и n=6.28 колебания затухают практически за один период, а скорость w1 достигает установившегося значением с превышением его в переходном процессе (перерегулированием) около 5%. При m<2 затухание колебаний ухудшается и перегулирование сильно возрастает.

Таким образом канал w0®w1 рассматриваемого ЭМТ с линейной механической характеристикой вследствие электромагнитной инерции представляет собой в данном случае колебательное звено, показатели колебательности которого n и x зависят только от соотношения посто-янных времени m, а быстродействие определяется электромагнитной постоянной времени Тэ или при данном m- электромеханической постоянной времени Тм.

Мы здесь не будем проводить столь же детальный анализ динамических характеристик всех каналов. Имея выражения передаточных функций (2.5)-(2.7), это легко сделать по аналогичному алгоритму. Здесь отметим все же следующее:

1. Переходные процессы по характеру и длительности для всех каналов одинаковы, поскольку определяются одними и теми же корнями (собственными числами).

2. Для каналов Mc®w1 и w0®M при одинаковых прочих параметрах следует ожидать больших по величине динамических отклонений (перемахов и перерегулирований) из-за наличия в их составе дифференцирующих звеньев ( форсирующего звена первого порядка и идеального дифференцирующего звена).

3.Передаточная функция канала Mc®w1 имеет знак (-), указывающий на то, что с увеличением момента сопротивления (нагрузки) скорость двигателя падает из-за падающей механической характеристики ЭМП.

5. Канал w0®M не имеет статической характеристики. Это значит, что электромагнитный момент после окончания переходного процесса возвращается к одному и тому же установившемуся значению, не зависящему от управляющего воздействия w0 . Оно определяется приложенным моментом нагрузки Mc.

При решении любых задач нужно уметь оценить влияние упругих связей на динамику ЭМС. Здесь мы проведем анализ особенностей вза-имодействия ЭМП с линейной механической характеристикой с меха-низмом, представленным двухмассовой моделью в единой ЭМС.

Возьмем за основу систему “ЭМП- механизм”, описываемую уравнениями состояния

dM/dt = (b/ Tэ) w0- (b/ Tэ)w1 -(1/ Tэ)M,

d w1/dt= - (1/ J1) M12 +(1/ J1) M -(1/ J1) Mc1

dM12 /dt =C12 w1 - C12 w2

dw2/dt= (1/ J2) M12 - (1/ J2) Mc2

Если пренебречь электромагнитной инерцией ЭМП, т.е. предположить, что Tэ =0 и рассматривать только свободное движение в системе (w0=0) , то первое уравнение системы превращается в алгебраическое и из него следует, что M=- bw1 .

Следовательно, при отсутствии электромагнитной инерции ЭМП создает воздействующий на первую массу механизма момент, аналогичный моменту вязкого трения ( момент, пропорциональный скорости). Значит, благодаря наличию электромеханической связи ЭМП должен оказывать на колебания в механической подсистеме демпфирующее воздействие, аналогичное действию сил вязкого трения.

Оценим такое воздействие в системе с J2>>J1 при w2@ 0 , что равносильно жесткой заделке второй массы. Такая система может быть описана парой уравнений

d w1/dt= - (1/ J1) M12 +(1/ J1) M -(1/ J1) Mc1

dM12 /dt =C12 w1 - C12 w2

с учетом принятых допущений принимающих вид

d w1/dt= -(b/ J1) w1 - (1/ J1) M12 -(1/ J1) Mc1

dM12 /dt =C12 w1 - 0 М12

Характеристическое уравнение подсистемы имеет принимает вид

Вводя понятие собственной резонансной частоты первой массы при жесткой заделке второй

перепишем характеристическое уравнение так

.

Корни уравнения равны

Анализируя собственные числа системы, легко установить, что

-при жесткости b электромеханического преобразователя, отличной от нуля, свободное движение системы является принципиально затухающим.

-изменение жесткости механической характеристики ЭМП является эффективным средством изменения колебательности системы с упругими связями в механизме


ЛЕКЦИЯ 3

ЛИНЕЙНЫЕ АЛГОРИТМЫ УПРАВЛЕНИЯ И РЕГУЛЯТОРЫ

Поскольку основная задача регулятора - осуществлять регули-рующее воздействие с минимальной погрешностью, выбор и настройка этих устройств являются одной из наиболее важных проблем, стоящих перед инженером- электромехаником- разработчиком ЭМС.

Регулятор выполняет преобразование управляющего сигнала e(t) , соответствующее математическим операциям, требуемым по условиям работы системы регулирования. К типовым требуемым операциям относятся следующие: пропорциональное, интегральное, пропорцио-нально-интегральное, пропорционально-дифференциальное, пропор-ционально-дифференциально-интегральное и т.п.

Рассмотрим более подробно функциональные связи между регу-лирующим воздействием и ошибкой, которые используются в ЭМС. Эти функциональные связи называются законами регулирования.

1. Пропорциональное регулирование

В простейшем случае пропорциональное регулирование осуществляется с использованием в качестве регулятора пропорционального звена с коэффициентом передачи Kp, так что

u(t)= Kп e(t).

Передаточная функция регулятора таким образом имеет вид

Wп(p)=U(p)/ e(p)= Kп

Практически пропорциональный регулятор (П-регулятор) в боль-шинстве случаев реализуется на базе операционного усилителя с жесткой обратной связью по напряжению как показано на рис. 3.1.

2.Интегральное регулирование

При интегральном регулировании осуществляется пропор-циональная зависимость между скоростью изменения регулирующего воздействия и ошибкой, т.е.

du/dt= Ки e(t).

Следовательно, регулирующее воздействие получается пропор-циональным интегралу от ошибки по времени

u(t)= Ки ò e (t) dt

Передаточная функция регулятора определяется выражением

WR(p)=U(p)/e(p)= Ки /p =1/Тиp, где Ти=1/Ки

Аналоговый интегральный регулятор как правило реализуется на базе операционного усилителя с включением в цепь отрицательной обратной связи конденсатора, как показано на рис. 3.2.

Передаточная функция такого устройства может быть найдена как

Wи(p)= 1/ R1Cp=1/Tи p,

где Tи=R1C-постоянная времени интегрирующего звена, измеряемая в секундах. Сравнивая последнее выражение с исходным, установим что 1/Tи= Ки. .

Переходная характеристика регулятора представляет собой линейно-изменяющуюся функцию времени. Скорость изменения определяется коэффициентом передачи Ки.

Детализированная структурная схема И-регулятора представлена на рис.3.3.

Математическую модель И-регулятора составляют следующие уравнения

e= [image] ; Uу= yи /Ти.

Этот регулятор обладает характерной особенностью: Выходная величина u неизменна только при нулевом отклонении регулируемой величины от заданного значения (при нулевой ошибке). Следовательно, установившийся режим в системе с И-регулятором может иметь место только при равенстве истинного и заданного значения регулируемой величины (при нулевой ошибке).

3. Пропорционально-интегральное (изодромное) регулирование

При изодромном регулировании осуществляется регулирование по пропорциональному и интегральному принципам, т.е.

u(t)=K1 e(t) + K2 ò e(t) dt

Следовательно, изодромное регулирование призвано совместить высокую статическую точность интегрального регулирования с большим быстродействием пропорционального регулирования.

Часто уравнение ПИ-регулятора записывается в следующем виде

u(t)= Кп [ e + (1/ Ти) ò e (t) dt ],

где Ки - коэффициент пропорциональности ПИ-регулятора, а Tи - время изодрома или время удвоения.

Последнему выражению соответствует следующая передаточная функция регулятора

Wпи(p)=

Такая передаточная функция в самом простом варианте может быть реализована на базе интегрального операционного усилителя в виде схемы (рис. 5.5)

Здесь: Tи = R2 C, сек и Kи= R2/R1

Поскольку ПИ-регулятор можно представить в виде параллельно включенных П-регулятора с коэффициентом передачи Kп и И-регулятора с коэффициентом передачи Kп/Ти , реакция такого регулятора на единичный скачек ошибки или переходная характе-ристика может быть представлена в виде суммы реакций параллельных каналов, т.е

h(t)= h1(t) + h2(t) = Кп+(Кп/Ти)t

где h1(t)- реакция П-канала в виде скачка с амплитудой Kп , а h2(t)-рекция И-канала в виде линейно возрастающей функции времени. Причем за время Ти функция возрастает на величину Kп. Поэтому постоянную времени интегрирования Ти часто называют временем изодрома или временем удвоения . Сказанное иллюстрируется рисунком 3.5

Рис.3.5

Детализированная структурная схема ПИ-регулятора представлена на рис.3.6.

Рис.3.6

Математическую модель ПИ-регулятора составляют следующие уравнения

e= [image] ; Uу= yи ( Кп/Ти) + Кпe.

4. Регулирование по производным

При регулировании по первой производной от ошибки реализуется зависимость

u(t)= Kд de (t) / dt,

Регулирующее воздействие (выходной сигнал регулятора) пропорционально скорости изменения ошибки. Это регулирование не имеет самостоятельного значения, т.к. в установившемся состоянии производная от ошибки равно нулю и регулирование пропадает. Однако оно может играть весьма большую роль в переходных процессах и вообще в динамике в качестве вспомогательного средства, так такое регулирование позврляет учитывать не только наличие ошибки, но и тенденцию к ее изменению (росту или уменьшению).

Логичным является формирование управляющего воздействия с учетом как самой ошибки, так и скорости ее изменения. Регулятор, реализующий такое управление носит название пропорционально- дифференциального или просто ПД- регулятора. Математически такой закон управления можно записать в виде

u(t)= Kпe (t) + Kд de (t) / dt,

что позволяет представить структурно ПД-регулятор в виде параллельного соединения П- и Д- регуляторов с суммированием их управляющих воздействий.

В результате введение регулирование по производной от ошибки увеличивает скорость реакции системы регулирования, то есть повышает ее быстродействие, что приводит к снижению ошибок в динамике.

Часто передаточную функцию ПД-регулятора записывают в виде

Wпд(p)= Kп+ Кдp= Kп(T1p+1)

У идеального ПД-регулятора при воздействии единичной ступенчатой функции на его вход в момент времени t=0 на выходе появляется d - функция, имеющая известное аналитическое выражение

æ ¥ при t=0

d(t)= í

è 0 при t¹0

Аналитическое переходная характеристики идеального ПД-регулятора рассчитывается по формуле

h(t)= Kп [ 1 + d(t) ] ,

а график ее представлен на рисунке 3.7.

Формально ПД-регулятор может быть реализован на базе интегрального операционного усилителя по схеме рис.3.8

где Kп= - R2/ R1 и T1=R1C, сек.

Однако работа данной схемы сопровождается значительными высокочастотными помехами, для которых конденсатор C представляет собой сопротивление близкое к нулю. Для повышения устойчивости работы ПД-регулятора последовательно с конденсатором включается дополнительный резистор R3 с небольшим сопротивлением, которое ограничивает токи высокочастотных помех. Этот резистор на рисунке показан штриховой линией.

При наличии такого резистора передаточная функция регулятора приобретает вид

,

где T1=(R1+R3)C, сек и T2=R3C, сек.

Таким образом регулятор приобретает инерционное звено первого порядка, что искажает переходную характеристику.Проблема уменьшения влияния дополнительной инерционности возникает всегда при реализации ПД-закона регулирования на аналоговой элементной базе.

Детализированная структурная схема ПД-регулятора представлена на рис.3.9.

Рис.3.9

Математическую модель ПД-регулятора составляют следующие уравнения

= e - yи /Т2;

Uу= yи [ (Кп/Т2)- (Кп Т1/Т22 )] + Кпe Т1/Т2.

В некоторых случах в закон регулирования могут вводиться производные более высоких порядков -вторая, третья и т.д. Это призвано улучшить динамические характеристики системы, однако техническая реализация ввдения производных выше второго порядка встречает значительные трудности.

5. ПИД-регулирование

Регулирующее воздействие, формируемое ПИД-регулятором пропорционально ошибе , скорости изменения ошибки и интегралу от ошибки, т.е.

u(t)= K1e (t) + K3 de (t) / dt+ K2 ò e (t)

Более распространенной в литературе является следующая форма записи ПИД-закона регулирования

u(t)= Кп [ e + (1/Tи) ò e (t) dt+ Tд de (t) / dt],

причем величина Tд, характеризующая степень введения производной в закон регулирования, называется временем предварения. В динами-ческом отношении эти регуляторы подобны системе из трех параллельно включенных звеньев: пропрционального, интегрирующего и дифференцирующего. При Tд=0 регулятор превращается в ПИ регулятор. Если, кроме того, Tи®¥, то получим П-регулятор.

Передаточная функция ПИД-регулятора может быть получена как

Wпид(p)= Kп + Kп/ Tи p + KпTд p =

Если на параметры Kп ,Tи и Tд наложить ограничение Ти³ 10 Тд

то указанная передаточная функция может быть преобразована к виду

Wпид(p)= [image] .

Аналитическое выражение переходной функции регулятора содержит три слагаемых (по числу составляющих реакции), т.е.

h(t)= Kп [ 1 + Tд d(t) + t/Tи] ,

Этому выражению соответствуют временные зависимости, представленные на рис. 3.10.

отличающаяся от соответствующей зависимости для ПИ-регулятора наличием всплеска в момент времени t=0 бесконечно большой амплитуды (теоретически) с площадью, определяемой величиной Tд.

Одна из множества возможных реализаций ПИД-регулятора на базе интегрального операционного усилителя представлена схемой на рис. 3.11.

Передаточную функцию реализованного таким образом регулятора получим следующим образом

Z2(p)= R2 +1/ C2p=

Z1(p)=

W(p)=

Следовательно; Кп= R2/R1; Ти=R2C2, с ; Тд=R1C1, с.

Для снижения уровня помех на выходе регулятора и повышения устойчивости его работы последовательно с конденсаторм С1 может быть включен дополнитеьный резистор R3 с небольшим сопротивле-нием, как это делалось в схеме с ПД-регулятором. Этот резистор точно таким же образом влияет на все динамические характристики регулятора.

При наличии дополнительного резистора R3 предаточная функция регулятора описывается выражением

Wпид(p)= [image] ,

где
Tv = R3C1; Tд=
(R3+R1)C1; Tи=R2C2;
Кп=R2/R1

С учетом инерционности, неибежно появляющейся при реализации ПИД- регулятора, передаточную функцию последнего запишем в виде

WR(p)=Uу(p)/e(p)= [image] .

где Тv- постоянная времени дополнительного инерционного звена или

WR(p)=Uу(p)/e(p)=

ДСС системы представлена на рис.3.12

Подпись: Рис.5.17

где yp2 и yp1 - выходные координаты (переменные состояния) интеграторов модели ПИД-регулятора.

Уравнения состояния ПИД-регулятора примут при этом вид

=

= e - (1/Tv)

uу= (Кп/Тv Ти.)yp1+ (Кп/Тv ) [image] + (КпТд/Тv ) [image] .

или

=

= e - (1/Tv)

uу = [image] yp1+ [image] [image] - + [image] e


Оптимизация линейных контуров регулирования

ЛЕКЦИЯ 4

Оптимизация линейных контуров регулирования

Задача оптимизации и типовые настройки контуров

Обобщенная структурная схема линейного контура регулирования представлена на рис. 4.1.

Если данные и свойства объекта регулирования известны, то задача синтеза состоит в таком выборе регулятора и его параметров, при которых формируемое им управляющее водействие u(t) было бы в состоянии как можно быстро, точно и без возникновения колебаний заставить регулируемую величину X следовать за задающим воздействием Xзад и нейтрализовать возмущения F.

Идеальная система, следовательно, должна удовлетворять следующим двум условиям

Wз у (p)= X(p)/ Xзад(p)=1

Wз в (p)= X(p)/F(p)=0

Можно сказать, что модуль АФЧХ замкнутой системы в идеальном случае должен быть равен единице во всем диапазоне частот изменения управляющего воздействия (прямая1 на рис.4.2)

При наличии инерционности в объекте регулирования указанные условия практически не реализуемы и можно говорить лишь о приближе-нии в максимально возможном диапазоне частот модуля реальной АФЧХ к единице.

В большинстве же случаев ставится задача - ликвидировать влияние инерции объекта настолько полно, насколько это окажется возможным за счет выбора оптимального типа регулятора и его настроек. Такую задачу и называют оптимизацией.

При оптимизации стремятся приблизить АФЧХ замкнутого контура к единице в возможно более широкой полосе частот и при этом обеспечить устойчивость контура и хорошо демпфированный слабоколебательный переходный процесс с минимальным временем.. Сама АФЧХ при этом принимает вид кривой “2” на рис. 4.2.

Такая пригонка обеспечивает высокую точность воспроизведения контуром регулирования управляющих и возмущающих воздействий в нижнем диапазоне частот и рост погрешностей с ростом частот этих воздействий. Чем шире диапазон частот, где АФЧХ замкнутой системы близка к единице, тем более высокие частоты может воспроизводить или парировать система.

Основные характеристики контуров, настроенных на технический оптимум

При настройке на "технический оптимум" передаточную функцию замкнутой системы управления с единичной обратной связью приводят к виду

, (4.1)

где Tm -эквивалентная некомпенсированная постоянная времени системы.

Полином знаменателя (характеристическое уравнение) оптимизи-рованного замкнутого контура имеет пару комплексно-сопряженных корней вида

,

где d = 1/2Tm и W св=1/ 2Tm

и следовательно, переходная характеристика оптимизированного контура определяется выражением

(4.2)

График переходной характеристики оптимизированного контура имеет при этом вид

Из рисунка видно, что

-время первого достижения функцией уровня нового устано-вившегося значения равно

tр1= 4.7 Tm .

-время переходного процесса (время вхождения в область значений, отличающихся не более чем на 5% от установившегося значения равно

tп= 6 Tm .

- а перерегулирование

D Xмакс= 4.3%

Эти характеристики типичны для любого контура, настроенного на технический оптимум и при изменении величины малой некомпенсированной постоянной времени Tm меняется лишь масштаб по оси времени.

При настройке на симметричный оптимум передаточная функция замкнутого контура приводится к виду

(4.4)

Среди полюсов передаточной функции (корней полинома знаменателя) имеется один вещественный корень

p1= - 1/2 Tm

и пара комплексно-сопряженных корней

p2,3= -1/4 Tm ± j(Ö3/4 Tm)

Находя переходную характеристику контура как

h(t)=L-1{W(p)/p},

получим

h(t)= [image] (4.5)

Последнему выражению соответствует следующий график

Из графика видно, что

- время первого согласования для симметрично оптимизированного контура

tр1= 3.1 Tm .

-время переходного процесса (время вхождения в область значений, отличающихся не более чем на 5% от установившегося значения равно

tп= 12Tm .

- а перерегулирование

D Xмакс= 43%

Настройка на “технический оптимум”

Передаточной функцией вида (4.1) соответствующей контуру, настроенному на технический оптимум, описывается система, имеющая в прямом канале звено с передаточной функцией

(4.6)

и охваченное единичной обратной связью с выхода на вход этого звена.

Если имеет место последовательная коррекция контура и регулятор с передаточной функцией WR(p) включен последовательно с объектом, обладающим передаточной функцией Wоб(p), то контур будет настроен на технический оптимум, если выполняется условие

Wрэ1(p)= WR(p) Wоб(p), (4.7)

Таким образом, оптимизация практически состоит в пригонке передаточной функции прямого канала оптимизируемой системы к эталонному виду путем выбора подходящего типа регулятора и его настроек.

Примем, что передаточная функция объекта регулирования имеет вид

, (4.8)

где t - постоянное запаздывание, а Ti- постоянные времени элементов объекта, расположенные в порядке убывания по значению и рассмотрим несколько частных случаев.

1. Пусть объект содержит ряд апериодических звеньев первого порядка постоянные времени объекта - соизмеримы и tз=0.

В этом случае оптимизация контура проводится с использованием И-регулятора. Передаточная функция разомкнутого контура при этом записывется в виде

(4.9)

При оптимизации последовательное соединение из n инерционных звеньев заменяется одним апериодическим звеном с эквивалентной постоянной времени

,

так, что

. (4.10)

Основанием для замены последовательно-включенных инерционных звеньев первого порядка одним эквивалентным апериодическим звеном является сходство реакций разомкнутых систем, описываемых передаточными функциями (4.9 ) и (4.10 ) , на скачкообразное входное воздействие. Реакция системы с эквивалентным апериодическим звеном, обладающим постоянной времени Tm представлена кривой 1 на рис. 4.5 .

Кривая 2 иллюстрирует реакцию системы из n последовательно включенных инерционных звеньев с суммой постоянных Tm. Кривая 3 иллюстрирует установившееся движение системы. Она представляет собою линейно возрастающую функцию времени, со скоростью, определяемой параметрами И-регулятора и смещением относительно времени подачи воздействия на величину Tm . С ростом числа n при неизменной суммарной постоянной времени Tm кривая реакции теснее прилегает к оси времени и при n®¥ совпадает с этой осью, что характерно для системы с чистым запаздыванием (t = Tm ).

Из сказанного можно сделать следующие выводы

- последовательное соединение большого числа инерционных звеньев без большого ущерба для точности можно заменить одним инерционным звеном, постоянная времени которого Tm равна сумме постоянных времени инерционных звеньев. При этом надо, чтобы в контуре имелось хотя бы одно интегрирующее звено или хотя бы одно инерционное звено с постоянной времени во много раз большей, чем сумма малых постоянных времени,

Выбор параметров регулятора осуществляется из условия

=

Следовательно,

2 Tm= Ти/Коб ® Ти =2 Tm Коб

Время переходного процесса в оптимизированной контуре составляет величину 6 Tm

2. Пусть объект содержит ряд апериодических звеньев первого порядка постоянные времени объекта - соизмеримы и tз¹0.

В этом случае оптимизация контура осуществляется также с помощью И-регулятора, причем

+t.

Следует иметь ввиду, что апериодическое звено с эквивалентной постоянной времени Tm , является фиктивным и его инерционность не может скомпенсирована обычным образом с помощью одного ПД- или ПИ- регулятора. Поэтому постоянную времени Tm часто называют некомпенсированной постоянной времени.

3. Если объект с передаточной функцией общего вида содержит одно инерционное звено с большой постоянной времени Т1, такой что

Т1³ [image] +t.

то при оптимизации следует принять меры для компенсации этой большой постоянной с помощью ПИ-регулятора. Заменив звенья с малыми инерционностями и чистым запаздыванием одним эквивалентным апериодическим звеном с постоянной времени

Tm = [image] +t.

Тогда

Выбирая Ти=Т1, получим

Условием оптимальной настройки, кроме Ти=Т1 будет

2Tm = Т1/ Коб Кп ® Кп =Т1 / 2КобTm

Таким образом время переходного процесса в контуре, настроенном на “технический оптимум” полностью определяется величиной малой некомпенсированной постоянной времени Tm

tп=6 Tm

и повышение быстродействия достигается мерами по уменьшению этой постоянной.

в) Если в цепочке инерционных звеньев, из которых состоит объект находятся не одна, а две большие инерционности, т.е.

Т1> T2 > [image] +t.

то для оптимизации контура следует использовать ПИД-регулятор. Заменив цепочку звеньев с малой инерционностью одним апериодическим звеном первого порядка с постоянной времени

Tm = [image] +t.

запишем передаточную функцию разомкнутой системы в виде

где Ти и Тд - соответственно время изодрома и время предварения ПИД-регулятора.

Выбирая Ти=Т1 и Тд=Т2 , получим

Условием оптимальной настройки, кроме Ти=Т1 и Тд=Т2 будет

2Tm = Т1/ Коб Кп ® Кп =Т1 / 2КобTm

Следует заметить, что большую из двух постоянных необходимо всегда компенсировать временем изодрома, а меньшую - временем предварения. Это связано со спецификой реализации ПИД-регулятора и взаимозависимостью параметров его настроек.

Исключение из передаточной функции разомкнутого контура звеньев с большими и средними постоянными времени открывает возможности повышения быстродействия контура регулирования. Эта операция реальные физические инерционные звенья из контура разумеется не исключает. Однако их действие, замедляющее протекание переходных процессов, компенсируется действием соответствующих форсирующих звеньев, содержащихся в регуляторе, ускоряющих в требуемой степени реакцию системы.

Пытаться компенсировать весьма малые постоянные времени нецелесообразно, так как технические трудности компенсации быстро возрастают при уменьшении значений постоянных времени, а влияние на быстродействие системы соответственно убывает. Особые трудности представляет компенсация дискретности и малого запаздывания ряда быстродействующих электрических преобразователей.

Настройка на “симметричный оптимум”

Передаточной функцией соответствующей контуру, настроенному на симметричный оптимум, описывается система, имеющая в прямом канале звено с передаточной функцией

(4.11)

и охваченное единичной обратной связью с выхода на вход этого звена.

И в этом случае оптимизация практически состоит в пригонке передаточной функции прямого канала оптимизируемой системы к эталонному виду (4.11) путем выбора подходящего типа регулятора и его настроек. Основные приемы оптимизации - те же, что и в рассмотренных ранее случаях

а). Если объект содержит одно интегирующее и одно инерционное звено первого порядка, т.е.

,

то для оптимизации контура используется ПИ-регулятор.

Если время изодрома регулятора выбрать из условия компенсации постоянной времени объекта (Ти=Тоб) , то передаточная функция разомкнутого контура примет вид

и замкнутая единичной обратной связью система будет находиться на границе устойчивости при любом значении коэффициента передачи Кп (настроечного параметра) . Следовательно, в данном случае компен-сировать постоянную времени объекта нельзя и последнюю следует принять в качестве некомпенсируемой постоянной Tm (Tm =Tоб). Для пригонки передаточной функции разомкнутой системы к эталонной (4.11) остается выполнить условия

4Tm =Tи и Tm / Коб Кп = 8Tm2 ® Кп=1/ 8 Tоб Коб

Нетрудно установить, что время переходного процесса в замкнутом контуре составляет величину tп=12 Tоб .

б).Если объект содержит интегрирующее звено и ряд инерционных звеньев с соизмеримыми постоянными времени Тi, то как и ранее последние следует заменить одним эквивалентным апериодическим звеном с эквивалентной постоянной времени

,

в) Если объект с передаточной функцией общего вида содержит одно инерционное звено с большой постоянной времени Т1, такой что

Т1³

то при оптимизации следует принять меры для компенсации этой большой постоянной с помощью ПИД-регулятора. Заменим звенья с малыми инерционностями и чистым запаздыванием одним эквивалентным апериодическим звеном с постоянной времени

Tm = [image] +t.

Тогда

Выбирая Тд=Т1, получим

Условием оптимальной настройки, кроме Тд=Т1 будут условия

4Tm =Tи и Tm / Коб Кп = 8Tm2 ® Кп=1/ 8 Tm Коб

Таким образом время переходного процесса в контуре, настроенном на “симметричный оптимум” полностью определяется величиной малой некомпенсированной постоянной времени Tm

tп=12 Tm

и повышение быстродействия достигается мерами по уменьшению этой постоянной.


ЛЕКЦИЯ 11

ЛЕКЦИЯ 5

РЕГУЛИРОВАНИЕ КООРДИНАТ ЭМС

При управлении технологическим процессом установки необходимо управлять потоком электрической энергии, потребляемой или вырабатываемой ЭМП таким образом, чтобы механические переменные - момент двигателя, скорость и ускорение механизма или положение его рабочего органа - либо поддерживались на требуемом уровне, либо изменялись по заданным законам с требуемой точностью.

Для создания систем управления, отвечающих всему комплексу предъявляемых требований , необходимо знать возможности управления ЭМС в отношении регулирования главных координат и оценивать влияние регулирования каждой из них в отдельности на физические свойства ЭМС. Изложение этих вопросов и входит в содержание данного раздела.

РЕГУЛИРОВАНИЕ МОМЕНТА В СИСТЕМЕ “УПП-ЭМП”

Необходимость регулирования момента диктуется предъявляемыми к ЭМС требованиями:

-для нормального функционирования ЭМС необходимо при ее работе ограничивать момент и ток двигателя допустимыми значениями в переходных процессах пуска, торможения и приложения нагрузки.

- для механизмов, испытывающих при работе значительные перегрузки вплоть до стопорений рабочего органа, возникает необхо-димость непрерывного регулирования момента в целях ограничения динамических ударных нагрузок механического оборудования.

Проблемы регулирования момента

Рассмотрим обобщенную разомкнутую электромеханическую систему с известной структурной схемой (рис.5.1)

Структура описывается уравнениями

Tпр dw0/dt= Kпр uу - w0 (5.1)

Tэ dM/dt = b (w0-w1) - M, (5.2)

JS dw1/dt= M- Mc (5.3)

В установившемся режиме, когда все производные равны нулю, запишем систему так

0= Kпр uу - w0

0= b (w0-w1) - M,

0= M- Mc

Исключая последовательно переменные, получим уравнение семейства механических характеристик в виде

М= Kпр uу b - bw1 (5.4)

или

М= Мк -Dм (w1) (5.5)

где Мк= Kпр uу b - момент короткого замыкания, пропорциональный сигналу управления и Dм(w1)- отклоненение момента от Мк, обусловленное скоростью вращения (наличием электромеханической связи) . Семейство механических характеристик представлено на рис.5.2

С ростом сигнала управления uу возрастает момент короткого замыкания и механическая характеристика смещается вправо по оси моментов параллельно самой себе (Мк1 < Мк2 < Мк3 ). Рост скорости приводит к отклонению момента от заданного значения Мк тем в большей степени, чем выше значение модуля жесткости механической характеристики b. Результирующий момент падает с ростом скорости в двигательном режиме работы ЭМП и растет- в режиме электромагнитного тормоза (если таковой обеспечивается схемой электрического преобразователя). Иными словами, при регулировании момента электромеханическая связь оказывается сильным возмущением и с точки зрения регулирования момента необходимо искать методы, позволяющие уменьшать модуль статической жесткости b.

Однако, бесконечно большое увеличение сигнала управления не приводит к такому же возрастанию момента Мк, который мы будем принимать условно за заданное значение момента в системе регулирования момента. Причиной является ограничение выходного сигнала электрического преобразователя на уровне w0 гр , поскольку подавляющее большинство преобразователей можно считать звеньями с явно выраженным насыщением. Последние имеют статическую характеристику следующего вида (рис.5.3)

Следовательно, максимальное значение момента короткого замыкания ограничено на уровне Мк гр = bw0 гр . Этому значению пускового момента соответствует механическая характеристика

М= Мк гр -bw1 , (5.6)

которую мы будем называть предельной механической характеристикой. На рис. 5.2 она выделена жирной линией.

Таким образом идеальной системой с позиции регулирования электромагнитного момента следовало бы считать систему, у которой

а) механическая характеристика была бы параллельна оси скоростей (см. кривую на рис.5.2 ), что означает, что электромагнитный момент не зависит от скорости вращения ,

б) статическая регулировочная характеристика Мк(uу) была бы линейной в диапазоне 0 <Мк < Мк гр

в) реакция системы на скачки управляющего uу и возмущающего w1 воздействий должна быть по возможности мгновенной ( динамические качества системы должны быть высокими)

В системе с управлением ЭМП от электрического преобразователя указанная цель достигается введением отрицательной обратной связи по моменту на вход управляемого преобразователя в соответствии со структурной схемой (рис.5.4)

uзад uу М Мс

Ä Р [image] Ä [image] Ä [image] w1

Kм

Рис.5.4

Механические характеристики системы “УПП-ЭМП” с отрицательной обратной связью по моменту и П-регулятором

Запишем управляющее воздействие на входе электрического пре-образователя в виде разности

uу= Kп(uзад - Км М), (5.7)

где uзад - сигнал, пропорциональный заданному значение момента, Км – коэффициент передачи датчика момента, Kп – коэффициент передачи П-регулятора. Тогда, исходную систему уравнений состояния можно переписать в виде

Tпр dw0/dt= - w0 -Kпр Kп Км М+ Kпр Kп Мзад (5.8)

Tэ dM/dt = b w0- M- bw1, (5.9)

JS dw1/dt= M- Mc (5.10)

Для установившегося режима уравнения принимают вид

0= - w0 -Kпр Kп Км М+ Kпр Kп uзад (5.11)

0 = b w0- M- bw1, (5.12)

0= M- Mc (5.13)

Находя из (11.11) w0 и подставляя его в (11.12), находим выражение, определяющее искомую механическую характеристику рассматриваемой системы :

(5.14)

После введения понятий петлевого коэффициента усиления

К0=bKпр KпКм

и заданного значения момента Мзад= uзад/Км уравнение механических характеристик примет вид

(5.15)

Приводя как и ранее данное уравнение к виду

М= Мк- Dм(v1),

получим, что

- момент короткого замыкания Мк пропорционален сигналу задания и его значение приближается к заданному значению момента Мзад с ростом петлевого коэффициента усиления К0 ;

- отклонение момента под воздействием скорости Dм(v1), также падает с ростом коэффициента передачи К0 в одинаковом диапазоне изменения скорости, т.е. падает эквивалентная жесткость механических характеристик. Вводя обозначение

получим D м(v1) = bэw1, где bэ - эквивалентная жесткость механических характеристик замкнутой по моменту системы. Как видно, с ростом петлевого усиления К0 жесткость механических характеристик системы падает и при К0 ®¥ bт®0.

Семейство механических характеристик системы с отрицательной обратной связью по току, соответствующее одному заданному значению момента Мзад и трем различным значениям петлевого коэффициента усиления К01 <К02 <К03 приведено на рис. 5.5.

УНИФИЦИРОВАННЫЙ КОНТУР РЕГУЛИРОВАНИЯ МОМЕНТА

Беспредельное увеличение петлевого усиления в системе с отрицательной обратной связью по моменту, рассмотренной выше, с целью снижения жесткости механических характеристик, неизбежно приведет к возрастанию колебательности переходного процесса и в конце концов к потере устойчивости системы, что потребует, естественно, принятия мер по динамической коррекции системы. Эта проблема легко решается введением ПИ-регулятора в прямой канал контура и настройкой его на технический оптимум. Таким образом и строятся унифицированные контура регулирования момента.

Структурная схема и математическая модель контура

Рис.5.6

Математическую модель контура образуют уже известные уравнения обобщенной энергетической подсистемы ЭПС (5.1)-(5.3), уравнение замыкания

e= uзад - Км М (5.16)

и уравнения ПИ-регулятора момента. Последние получены лекциях 5,6 и имеют вид

dyи/dt= e ; (5.17)

uу = Кп e +(Кп /Tи) yи (5.18)

где e - ошибка системы и yи -выходной сигнал интегратора ПИ- регулятора. Подставляя (12.1) в (12.2) и (12.3), получим

dyи/dt= -КмМ+uзад; (5.19)

uу=Кпuзад-КпКмМ+(Кп/Tи)yи (5.20)

Подставляя (5.20) в (5.1) получим уравнения, составляющие математическую модель рассматриваемого контура регулирования момента в следующем виде

Tпр dw0/dt= - w0- Kпр КпКмМ +( Kпр Кп/Tи)yи +-Kпр Кп uзад (5.21)

Tэ dM/dt = - M +bw0-bw1, (5.22)

JS dw1/dt= M- Mc (5.23)

dyи/dt= -КмМ+uзад; (5.24)

Статические характеристики контура

Анализируя уравнение (5.18) регулятора, легко заключить, что в установившемся режиме при постоянных задающем и возмущающем воз-действиях статическая ошибка принципиально равна нулю независимо от параметров звеньев системы и от величины внешнего возмущения w1, т.е.

М=Мзад =Uзад/Км

Графики статических регулировочных и механических характеристик контура изображены соответственно на рис. 5.7 и 5.8

Заметим, что в данной системе с ПИ-регулятором нулевая жесткость механических характеристик и статическая ошибка обеспечена структурно и независимо от конкретных параметров электрического преобразователя, двигателя и регулятора . Варьируя последними можно изменять быстродействие и качество переходных процессов, также как и динамические ошибки по управлению и возмущению , не влияя на характеристики установившегося режима.

Оптимизация контура регулирования момента

Как было показано выше, при регулировании момента электро-механическая связь является возмущающим воздействием, снижающим точность регулирования. Поскольку в системе с отрицательной обратной связью по моменту влияние этой связи в значительной степени ослаблено, разомкнем эту связь при синтезе контура регулирования, пренебрегая ее влиянием на динамику контура в процессах по управлению. Влияние этой связи на динамическую точность регулирования в дальнейшем будем оценивать, считая изменения скорости независимым возмущающим водействием {f(t)= w1}. Структурная схема контура примет при этом вид рис.5.9

Рис.5.9

Настроим контур на технический оптимум, используя ПИ-регулятор. Поскольку обычно Тэ>>Тпр и, кроме того, инерционность преобразователя обычно компенсировать нельзя, то примем постоянную времени преобразователя примем в качестве малой некомпенсированной постоянной (Тпр=Тm1) и выберем время изодрома регулятора из условия компенсации постоянной времени Тэ, т.е. Ти=Тэ Тогда передаточная функция разомкнутого внутреннего контура примет вид

Оптимизируя контур, найдем

2Tпр = Тэ/ Кпр Кп Кмb ® Кп =Тэ / 2Кпрb Tпр Км

Передаточная функция замкнутого контура регулирования момента примет вид

или

Характер переходного процесса соответствует стандартному, а время процесса составляет величину » 6 Тпр.

ДИНАМИЧЕСКИЕ ХАРАКТЕРИСТИКИ КОНТУРА

Реакция контура на скачок задающего воздействия при заторможенном роторе ЭМП соответствует расчетной. Изменение скорости ЭМП (возмущающего воздействия для контура тока) из-за наличия электромеханической связи вызывают отличие реального переходного процесса от расчетного. Выражение, определяющее переходный процесс по управлению в контуре тока при наличии электро-механической связи в ЭМП получается достаточно громоздким, а вывод его - трудоемок. Поэтому мы оценим здесь влияние электромеханической связи на переходный процесс приближенно

Влияние динамического возмущения на переходный процесс по управлению можно оценить, зная передаточную функцию оптимизированного контура по возмущению.

Wв(p)= M(p)/w1(p)= Wзэ(p)/WR(p)Wпр(p)=

С учетом того, что Кп =Тэ / 2КпрbTпр Км , последнее выражение приведем к виду

Wв(p)=

или после замены оптимизированного контура эквивалентным апериодическим звеном

Wв(p)=

Реакция оптимизированного контура на скачкообразное возмущение не представляет интереса, поскольку возмущением является скорость w1, а последняя принципиально скачком изменяться не может. Характерными для контура являются возмущения по характеру гармонические (особенно при наличии упругих связей в механической подсистеме) или изменяющиеся во времени по закону, близкому к линейному.

Проанализируем далее влияние линейно-изменяющегося во времени возмущения w1(t)= et на реакцию контура на скачкообразное изменение управляющего воздействия Мзад при нулевых начальных условиях.

Используя принцип суперпозиции найдем реакцию контура на одновременно действующие управляющее Мзад(t)=const и возмущающее w1(t)= et воздействия в виде суммы двух составляющих, т.е.

M(t)= X1(t) - X2(t).

Первая составляющая представляет собой стандартную реакцию оптимизированного контура на скачок управляющего (задающего) воздействия при отсутствии возмущения, т.е.

X1(t) = Мзад (1-е-t/2Тпр)

Вторая составляющая представляет собой реакцию оптимизи-рованного контура на возмущающее воздействие заданного вида при отсутствии задающего воздействия. Его мы найдем, используя пере-даточную функцию контура по возмущению, как

X2(t)= L-1{(e/p2)Wв(p)}

или

X2(t)= L-1{ [image] }

Находя

,

установим, что эта реакция содержит постоянную составляющую в виде моментной ошибки, пропорциональной скорости изменения возмущения e, жесткости механических характеристик ЭМП b и постоянной времени преобразователя Тпр. Далее эту ошибку мы будем обозначать как DМe.

Знаменатель изображения X2(p) имеет три корня: p1=0, p2=-1/Тэ и p3=-1/2Тпр. Используя формулу разложения, искомую реакцию можно найти в виде

X2(t)= DМe

где N(p)= 1+Тпрp. M’(p)= 6 ТэТпрp2 + (4Тпр+2Тэ)p+1

Следовательно,

М(t) = (Мзад -DМe ) -( Мзад +DМe [image] ) e -t/2Тпр

+DМe [image] e -t/тэ

Временные зависимости X1(t) , X2(t) , М(t) и w1(t) приведены на рисунке 5.10 .

Анализируя полученные временные зависимости, можно заключить, что

- линейно-возрастающее возмущение обуславливает появление статической ошибки DМe, пропорциональной скорости изменения возмущения,

- время реакции в общем случае возрастает относительно расчетного (6 Тпр), поскольку определяется электрической постоянной времени Тэ>> 2Тпр

- Кривая M(t) приближается к кривой X1(t) с уменьшением ошибки DМe, пропорциональной Тпр, в том случае, если преобразователь безинерционный (Тпр =0).


Лекция 13

Лекция 6

РЕГУЛИРОВАНИЕ СКОРОСТИ В СИСТЕМЕ “УПП-ЭМП”

Технологические режимы многих производственных механизмов на разных этапах работы требуют движения исполнительного органа с различной скоростью. Это обеспечивается либо механическим путем, либо путем электрического регулирования скорости.

Механические способы требуют введения в кинематическую цепь системы коробок передач или других устройств, усложняющих меха-ническую подсистему ЭМС и снижающих ее надежность.

Этого недостатка лишен второй путь- электрическое регулирование скорости с целью поддержания ее на заданном уровне или изменения ее во времени по требуемым законам с заданной точностью. Именно этим путем в современном электроприводе обеспечивается плавное регулирование скорости в диапазоне wмакс/wмин до 100000 . Вопросы организации систем автоматического регулирования скорости и рассматриваются в данном разделе.

Требования к системам регулирования скорости

Рассмотрим обобщенную разомкнутую электромеханическую систему с известной структурной схемой на рис.6.1

Структура описывается системой уравнений состояния

Tпр dw0/dt= Kпр uу - w0

Tэ dM/dt = b (w0-w1) - M,

JS dw1/dt= M- Mc

В установившемся режиме, когда все производные равны нулю, запишем систему так

0= Kпр uу - w0

0= b (w0-w1) - M,

0= M- Mc

Исключая последовательно переменные , получим уравнение семейства механических характеристик в виде

w1 = Kпр uу - Мс/ b

или

w1 = wх -Dм

где wх = Kпр uу - скорость холостого хода , пропорциональная сигналу управления и Dw(M)- отклоненение скорости от wх, обусловленное наличием статического момента нагрузки на валу Мс. Семейство механических характеристик представлено на рис. 6.2

С ростом сигнала управления uу возрастает скорость холостого хода и механическая характеристика смещается вверх по оси скоростей параллельно самой себе (wх1 < wх2 < wх3 ).

Рост момента нагрузки приводит к отклонению скорости от заданного значения wх тем в большей степени, чем ниже значение жесткости механической характеристики b. Результирующая скорость падает с ростом момента нагрузки в двигательном режиме работы ЭМП и растет- в генераторном режиме (если таковой обеспечивается схемой электрического преобразователя). Иными словами, при регулировании скорости момент нагрузки оказывается сильным возмущением и с точки зрения регулирования скорости необходимо искать методы, позволяющие повышать модуль статической жесткости b.

Однако, бесконечно большое увеличение сигнала управления не приводит к такому же возрастанию скорости wх , которую мы будем принимать условно за заданное значение скорости в системе регулирования скорости. Причиной является ограничение выходного сигнала электрического преобразователя на уровне w0гр . Следовательно, максимальное значение заданной скорости ограничено на уровне w0гр. Этому значению соответствует предельная механическая характеристика

w1 = w0 гр -Мс/ b ,

выделенная на рис. 6.2 жирной линией.

Таким образом идеальной системой с позиции регулирования скорости следовало бы считать систему, у которой

а) механическая характеристика была бы параллельна оси моментов, что означает, что скорость вращения не зависит от момента нагрузки

б) статическая регулировочная характеристика wх(uу) была бы линейной в диапазоне 0 <wх < w0 гр

в) реакция системы на скачки управляющего uу и возмущающего Мс воздействий должна быть по возможности мгновенной ( динамические качества системы должны быть высокими)

В системе с управлением ЭМП от электрического преобразователя указанная цель может быть достигнута введением отрицательной обратной связи по скорости на вход управляемого преобразователя в соответствии со структурной схемой, приведенной ниже.

Механические характеристики системы “УПП-ЭМП” с отрицательной обратной связью по скорости и П-регулятором

Представим управляющее воздействие uу на входе электрического преобразователя в виде разности

uу= Kп(uзад - Кw w1 ),

где uзад - сигнал, пропорциональный заданному значению скорости ,

Кw - коэффициент, характеризующий глубину отрицательной обратной связи по скорости.

Тогда, систему уравнений состояния можно переписать в виде

Tпр dw0/dt= - w0 - Kпр Kп Кw w1 + Kпр Kп Uзад

Tэ dM/dt = b w0- M- bw1,

JS dw1/dt= M- Mc

Для установившегося режима система принимает вид

0=- w0 - Kпр Kп Кw w1 + Kпр Kп Uзад

0 = b w0- M- bw1,

0= M- Mc

Последовательно, начиная с последнего уравнения, исключая переменные, находим выражение, определяющее статическую механическую характеристику искомой системы

После введения понятий петлевого коэффициента усиления

К0=Kпр KпКw

и заданного значения скорости w1зад= uзад/Кw уравнение механических характеристик примет вид

Приводя как и ранее данное уравнение к виду

w1 = w1х- Dw(М),

получим, что

- скорость холостого хода w1х пропорциональна сигналу задания и его значение приближаниеся к заданному значению w1зад с ростом петлевого коэффицинта усиления К0

- отклонение скорости под воздействием статического момента Dм также падает с ростом коэффициента передачи К0 в одинаковом диапазоне изменения момента, т.е. возрастает эквивалентная жесткость механических характеристик. Вводя обозначение

bэ ск=b(1+К0)

получим Dw = Мс/bэск, где bэск - жесткость механических характеристик замкнутой по скорости системы. Как видно, с ростом петлевого усиления К0 жесткость механических характеристик системы возрастает и при К0 ®¥ bэск®¥.

Семейство механических характеристик системы с отрицательной обратной связью по скорости, соответствующее одному заданному значению скорости w1зад и трем различным значениям петлевого коэф-фициента усиления К01 <К02 <К03 приведено на рис.6.4.

Легко показать, что отрицательная обратная связь по скорости оказывает форсирующее действие на замедленные инерцией электромеханические процессы в системе. Последние, как нам уже известно, во многом определяются электромеханической постоянной времени Тм=Jå/ b, обратно пропорциональной жесткости механических характеристик b. Увеличение петлевого усиления К0 приводит к уве-личению эквивалентной жесткости механических характеристик bск и как следствие, к снижению значения электромеханической постоянной времени, в тех случаях, пока выходное напряжение управляемого преобразователя в переходных процессах не выходит на уровень ограничения.

Однако беспредельное увеличение К0 с целью повышения жесткости механических характеристик при наличии электромагнитной инерции ЭМП и электрической инерции управляемого преобразователя может привести к росту колебательности переходных процессов и в конце концов к потере устойчивости системы регулирования скорости. Поэтому вопросы оптимизации контуров регулирования при достижении заданных точностных показателей и здесь является актуальными.

Одноконтурная система с ПИ-регулятором скорости

Такие системы находят применение в тех случаях, когда Тм>10Тэ , Тпр<< Тэ и по техническим требованиям недопустимы статические ошибки по задающему и возмущающему воздействиям.

Исходная структурная схема системы имеет вид

Математическая модель в переменных состояния

Дополним систему уравнений состояния разомкнутой электромеханической системы

Tпр dw0/dt= Kпр uу - w0

Tэ dM/dt = b (w0-w1) - M,

JS dw1/dt= M- Mc

уравнением замыкания

e= uзад - Кw w1

и системой уравнений, описывающих ПИ-регулятор. Поскольку структурная схема последнего имеет вид

Рис.6.6

где e - ошибка системы и yи -выходной сигнал интегратора регулятора, систему уравнений регулятора запишем как

dyи/dt= e; uу = Кп e +(Кп /Tи) yи

или с учетом уравнения замыкания

dyи/dt= uзад - Кw w1;

Тогда после тривиальных преобразований система уравнений состояния примет вид

Tпр dw0/dt= - w0 - К0 w1 + (К0 /Кw Tи) yи +K0 wзад

Tэ dM/dt = bw0 - M- bw1,

JS dw1/dt= M- Mc

dyи/dt= - Кw w1 + Кw wзад ;

Для установившегося режима M= Mc и w1 = wзад

Следовательно, в установившемся режиме при постоянном зада-ющем и возмущающем воздействиях статическая ошибка принци-пиально равна нулю независимо от параметров звеньев системы и от величины внешнего возмущения Мс, т.е. w1=w зад . Значит механические характеристики указанной системы будут иметь следующий вид

Оптимизация одноконтурной системы с ПИ-регулятором

После преобразований, структурную схему системы изобразим в следующем виде

Рис.6.8

Передаточная функция последнего звена представляет собой передаточную функцию линеаризованного ЭМП по моменту (возму-щению). При Тм>4 Тэ, как было установлено ранее, последняя может быть представлена в виде

Ww1, Mc(p) = [image] ,

где Т1 и Т2- постоянные времени, определяемые корнями полинома знаменателя передаточной функции

.

а именно Т1= mod (1/l1 ) и Т1= mod (1/l2 ), Обратим внимание на то обстоятельство, что T1>T2 и при Тм>>Тэ Т1®Тм и Т2®Тэ.

Cледовательно, расчетную структурную схему системы изобразить в виде

Заменим 2 инерционных звена с малыми (относительно Т1) постоянными времени (преобразователь и апериодическое звено с постоянной времени Т2) одним эквивалентным звеном с суммарной постоянной времени Тm=Тпр + Т2 . Тогда

Wр(p)=w1(p)/ wзад(p)=

Последняя передаточная функция соответствует эталонной передаточной функции системы, настроенной на технический оптимум

если,

а) время изодрома выбрано из условия компенсации постоянной времени Т1, т.е. Ти=Т1.

б) 2Тm= Ти/ K0 или К0= Т1/2Тm . Следовательно, значение петле-вого коэффициента усиления определяется соотношением постоянных времени Т1/2Тm. При этом коэффициент передачи ПИ-регулятора определяется выражением

Кп= Т1/2Тm Кпр Кw

Переходные процессы по управлению по характеру и времени соответствуют стандартным.

Исследуем далее реакцию контура на возмущение в виде момента. Для этого преобразуем структурную схему следующим образом:

После подстановки К0= Т1/2Тm получим

Wв(p)=Dw1(p)/DMc(p)=-

Находя предел

,

установим, что он равен нулю, и следовательно, регулируемая величина- скорость- в установившемся режиме не содержит ошибки, обусловленной статическим моментом нагрузки .

Найдем реакцию контура на скачок момента DМс при нулевых начальных условиях.

Dw1(t)= L-1{-(DMc/p) [image] }

Используя формулу разложения, находим

(6.1)

Временная зависимость, соответствующая полученной формуле (6.1) представлена на рис. 6.11.

Анализ ее показывает, что время парирования возмущения равно времени переходного процесса по управлению, т.е. tп @3 Т1

Для приближенной оценки максимального значения динамического отклонения скорости Dwмакс примем, что оно имеет место в момент времени

t*@ p Тm,

что соответствует четверти периода свободных колебаний скорости

Тсв=2p/wсв=4 p Тm.

При Тm<10 Т1 без большой порешности можно пользоваться для оценки максимального динамического отклонения скорости следующим соотношением

Выводы:

1. Статические и динамические одноконтурной системы с ПИ-регулятором относительно управляющего воздействия полностью соответствуют характеристикам эталонной системы, настроенной на технический оптимум, в предположении что малая некомпенсированная постоянная времени Тm=Тпр + Т2 . Быстродействие контура при этом практически определяется электрической постоянной времени Тэ, т.е. tп @ 6 Тэ .

2. Система не имеет статической ошибкой и по управлению и по возмущению независимо от ее параметров , что определено типом регулятора

3. Длительности переходных процессов по возмущению опреде-ляется самой большой постоянной времени Т1@ Тм .т.е. tп @ 3 Тм

4. Динамические отклонения скорости в процессе парирования скачкообразного изменения момента нагрузки прямо пропорциональны величине скачка DМс и некомпенсированной постоянной времени Тm и обратно пропорциональны жесткости механических характеристик собственно ЭМП и большой постоянной времени Т1 .


Структурная схема системы с ПИ-регулятором скорости

Лекция 7

Двухконтурная система с ПИ-регулятором скорости

В настоящее время при создании систем управления ЭМС широко применяется принцип последовательной коррекции или принцип подчиненного регулирования. Этот принцип состоит в следующем.

Объект регулирования представляется в виде последовательно соединенных звеньев Wоб1(p), Wоб2 (p), Wоб3(p) и т.д. с промежуточными координатами x1, x2, x3, ... и регулируемой (выходной) координатой X (см. структурную схему на рис.7.1. В качестве указанных координат используются существенные координаты, такие, например, как ток, магнитный поток, момент, скорость, положение. Для управления каждой координатой организуется отдельный контур со своей обратной связью и своим регулятором. На рис. 7.1 датчики координат представлены звеньями с коэффициентами передачи Kx1, Kx2 и Kx, а передаточные функции регуляторов обозначены через WR1, WR2, WR3.

Замкнутые контуры регулирования образуют систему, в которой имеется внутренний контур управления, состоящий из регулятора WR1 первого звена объекта Wоб1 и цепи обратной связи по координате X1, первый внешний контур, включающий в себя внутренний контур , второе звено объекта Wоб2, регулятор WR2 и цепь обратной связи по координате X2 и второй внешний контур, включающий в себя первый внешний контур, третье звено объекта управления Wоб3 , регулятор WR3 и обратную связь по координате X3, для рассматриваемого случая являющейся регулируемой, т.е. X3=X.

Выходной сигнал регулятора каждого внешнего контура является задающим для последующего, заключенного внутри него контура. Таким образом, каждый внутренний контур регулирования подчинен соответствующему внешнему.

Каскадные системы управления характеризуются лучшим качеством управления по сравнению с одноконтурными системами по следующим причинам:

- возмущения, F1(p) , F2(p), поступающие на части объекта, расположенные ближе к входу, прежде чем воздействовать на выходную координату X (регулируемую переменную) предварительно парируются во внутренних контурах управления

- наличие внутренних контуров уменьшает влияние изменения параметров входной части на динамические качества системы регулирования ( снижается чувствительность системы к изменению параметров объекта),

Практическое преимущество разделения системы на контура с основными и вспомогательными регуляторами состоит в том, что настройку их параметров можно осуществлять независимо и последовательно. Она осуществляется следующим образом:

1.Настройка первого внутреннего контура осуществляется на оптимум по модулю или симметричный оптимум.

2. При переходе к внешнему контуру передаточную функцию замкнутого внутреннего контура упрощают, аппроксимируя его апериодическим звеном первого порядка

Новую некомпенсированную постоянную выбирают с учетом быстродействия внутреннего контура и датчиков обратной связи. Если постоянные времени последних действительно малы, то их практически можно не выделять из других постоянных времени.

Если во внешнем контуре есть свои малые постоянные, то эквивалентная постоянная времени замкнутого внутреннего контура 2Тm1 входит в состав суммарной малой постоянной времени Тm2.

Если во внешнем контуре нет своих малых постоянных времени, то для него некомпенсируемая постоянная времени Тm2 выбирается равной 2Тm1. Настраивая первый внешний контур, например, на технический оптимум , получим его передаточную функцию в виде

3. Заменяя первый внешний контур эквивалентным апериодическим звеном, аналогичным образом осуществляем оптимизацию второго внешнего контура и т.д.

Легко установить, что быстродействие каждого внешнего контура не менее чем в 2 раза ниже быстродействия подчиненного ему внутреннего контура.

К преимуществам системы подчиненного регулирования можно отнести:

- простоту наладки и настройки (настройку в процессе наладки ведут начиная с внутреннего контура, а качество настройки может быть легко оценено по результатам сравнения реакции контура на скачок управляющего воздействия со стандартной переходной характеристикой)

- удобство ограничения предельных значений промежуточных координат системы ( поскольку выходной сигнал регулятора внешнего контура является сигналом задания для внутреннего контура ).

Недостаток описанного подхода - некоторый проигрыш по быстродействию , связанный с последовательным воздействием на объект через внутренние контура, а не сразу через входное звено объекта.

Структурная схема системы с ПИ-регулятором скорости представлена на рис. 7.2. ПИ- регулятор момента с коэффициентом передачи Кп1 и временем изодрома Ти1 представлен на рис.7.2 детализированной структурной схемой. Аналогично представлен ПИ-регулятор скорости с коэффициентом передачи Кп2 и временем изодрома Ти2 Через Eps1 и Eps2 обозначены ошибки соответственно на входах контуров регулирования момента и скорости. Выходное напряжение uзад(м) регулятора скорости является задающим для подчиненного контура регулирования момента.

Математическая модель системы содержит 5 уравнений состояния

Tпр dw0/dt= - w0 +Kпр uу

Tэ [image] = bw0 - M- bw1,

JS [image] = M- Mc

= Eps1

= Eps 2,

где к известным переменным состояния, характеризующим энергети-ческую подсистему ЭМС, добавлены выхолы интеграторов ПИ-регу-ляторов yp1 и yp2 , , характеризующие состояние информационной подсистемы.

Для формирования модели к уравнениям состояния следует добавить уравнения связей, по существу формирующие из задающего воздействия и координат состояния управляющее воздействие Uу на входе управляемого преобразователя (или на входе энергетической подсистемы). Как видно последнее связано с ошибками Eps2 ( на входе регулятора скорости) и Eps1 (на входе регулятора момента )

Eps2 = uзад - Кw w1

Eps1 = Eps2 Кп2 - Км М+ yp2 (Кп2/Ти2)

uу= Eps1Кп1 +(Кп1/Ти1)yp1

Исключая переменные ( в виде ошибок) из уравнений связи (последовательно, начиная с первого), получим

uу= Кп1 Кп2 uзад - Кп1 Кп2 Кw w1 - Кп1 Км М + yp1(Кп1/Ти1) - yp2 (Кп1Кп2/Ти2)

Оптимизация контуров регулирования

Внутренний (подчиненный ) контур регулирования момента имеет унифицированную структуру и содержит ПИ-регулятор момента , параметры которого выбираются из условия настройки контура на технический оптимум, т.е. Ти1= Тэ ; Тпр=Тm1 ; Кп 1=Тэ / 2КпрbTпр Км.

Передаточная функция замкнутого контура регулирования момента примет вид

,

или после известного упрощения

,

Тогда структурная схема контура регулирования скорости примет вид, показанный на рис. 7.3.

Передаточная функция разомкнутого контура

Wp(p)=w1(p)/ Eps*2(p)= [image] .

Сравнивая ее с передаточной функцией эталонной системы, настроенной на симметричный оптимум

и принимая в качестве малой некомпенсированной постоянной времени величину 2Тпр =Тm2=2 Тm1, получим параметры ПИ-регулятора скорости: время изодрома

Ти2= 4 Тm2 = 8Тпр

и коэффициент передачи Кп2 из условия

8Т2m2= КмТмb4Тm2 / Кп2Кw

Следовательно, Кп2 = КмТм b/ Кw 2Тm2

или

Кп2 = КмТм b/ Кw4Тпр

Статические и динамические характеристики контура с такими настройками относительно задающего (управляющего) воздействия соответствуют характеристикам стандартной системы, настроенной на симметричный оптимум. Передаточная функция замкнутого контура по управлению имеет вид

,

или

,

При этом

а) Контур не имеет статической и скоростной ошибки, относительно сигнала задания (система обладает астатизмом второго порядка по управлению). В литературе часто такую систему называют двукратно-интегрирующей.

б) Время переходного процесса по управлению составляет величину

tп @ 12Тm2 @ 24Тm1 @ 24Тпр ,

однозначно определяется величиной постоянной времени управляемого электрического преобразователя и в 4 раза превышает время переходного процесса в контуре регулирования момента.

в) Перерегулирование при отработке скачка задания контуром, настроенным на симметричный оптимум, составляет, как известно, величину 43%. Для уменьшения его до величины 8.3% на входе контура, в канале формирования сигнала задания устанавливается фильтр в виде апериодического звена с передаточной функцией

Wф(p)=uзад (p)/ uвх(p)= 1/ (Тфp +1),

причем постоянная времени фильтра выбирается из условия компенсации числителя передаточной функции замкнутой системы, т.е.

Тф= 4 Тm2 @ 8Тm1 @ 8Тпр.

Для учета такого фильтра математическую модель системы следует дополнить еще одним уравнением

Рассмотрим далее характеристики контура относительно возму-щающего воздействия (момента нагрузки Мс)

Преобразуя схему известным образом, приведем ее к виду, показанному на. 7.4. Передаточная функция системы по возмущению

Wв(p)=

с учетом выражения для коэффициента передачи ПИ-регулятора оптимизированного контура Кп2 = КмТм b/ Кw4Тпр приводится к виду

Wв(p)= [image] .

Тогда операторное изображение ошибки контура Dw(p) в виде изменения скорости, обусловленного скачкообразным приложением момента статической нагрузки при нулевом задании по скорости и нулевых начальных условиях можно представить выражением

Dw(p) = [image] .

Находя установившееся значение ошибки в системе как

,

установим, что эта ошибка равна нулю при любом моменте нагрузки Мс , и следовательно, в пределах зоны пропорциональности УПП механические характеристики определяются выражением w1=wзад и по форме не отличаются от аналогичных характеристик одноконтурной системы регулирования скорости с ПИ-регулятором.

Для оценки характера процесса парирования скачкообразного возмущения определим переходную характеристику системы по возмущению, используя операторное изображение ошибки

Dw(t) =

Корни полинома знаменателя выражения, заключенного в фигурные скобки, известны:

p1= -1/ 2Tm2=-1/4Tпр;

p2,3= -1/ 4Tm2 ±jÖ3/ 4Tm2=-1/ 8Tпр ±jÖ3/ 8Tпр

Используя формулу разложения, находим

(7.1)

График полученной зависимости представлен на рис. 7. 5. Анализ ее показывает, что время парирования возмущения равно времени переходного процесса по управлению, т.е. tп @24 Тпр .

Для приближенной оценки максимального значения динамического отклонения скорости Dwмакс заметим, что оно имеет место в момент времени

t*@6 Тпр

Подставляя значение t* в формулу 7.1, получим

Dwмакс@ Dw(t*)@ 3.54 (Мс/J) Тпр

Таким образом величина максимального динамического выброса скорости при парировании системой скачка момента нагрузки пропорциональна величине этого скачка и обратно пропорциональна моменту инерции ротора двигателя с нагрузкой. Важным является то обстоятельство, что величина указанного выброса снижается с уменьшением постоянной времени управляемого электрического преобразователя


Задачи позиционирования и слежения

ЛЕКЦИЯ 8

Следящие электроприводы

1. Структура и типовые режимы работы следящих приводов

Следящие электроприводы представляют собой замкнутые системы с главной отрицательной обратной связью по положению (углу поворота или линейному перемещению) выходного звена. Отличительной особенностью следящего электропривода является то, что задающий сигнал (входная координата) изменяется во времени произвольно. Задача следящей системы - обеспечить с требуемой точностью воспроизведение (отработку) любых законов движения, задаваемых командным (задающим устройством).

Функциональную схему следящего электропривода для самого общего случая можно изобразить в виде , показанном на рис. 8.1.

Рис.8.1

Следящий привод построен по принципу подчиненного регулирования и содержит три контура регулирования : положения, скорости и момента. Основной, внешний контур, или контур положения, включает задатчик положения ЗП, устройство сравнения заданного и истинного значения положения a, регулятор положения РП, подчиненный контур регулирования скорости, рабочий орган РО, датчик перемещения или угла поворота ДП. Электромеханический преобразователь (двигатель) ЭМП под действием системы управления передает движение рабочему органу таким образом, чтобы изменение во времени угла поворота следящей оси или положение рабочего органа a было пропорционально изменению сигналу задания по положению Хз.

Измеритель рассогласования сравнивает значение задающего сигнала Xз (или выходного сигнала задатчика положения) с сигналом Xa, пропорциональным истинному значению линейного или углового перемещения a, измеряемого датчиком положения ДП. Сигнал, пропорциональный рассогласованию Xd, подвергается преобразованию регулятором положения РП в соответствии с принятым алгоритмом управления и поступает на вход системы регулирования скорости в качестве сигнала задания.

Форма сигнала задания Xз зависит от назначения системы. В цифровых системах сигнал задания может поступать от ЭВМ высокого уровня в виде кода. В системах непрерывного действия задающим может быть угол поворота входного вала, напряжение, ток и некоторые другие формы сигнала. Тоже относится и к датчикам координат -положения, скорости момента и к соответствующим регуляторам . В зависимости от форм представления сигналов датчиков и регуляторов следящие системы делятся на непрерывные, импульсные и цифровые..

Для построения замкнутой системы следящего электропривода, вообще говоря, достаточно лишь одного внешнего контура, содержащего информацию о перемещении. Роль системы регулирования скорости выполняет разомкнутая система “УП-ЭМП” и при этом исключаются регуляторы и датчики скорости и момента. Однако из теории управления известно, что наличие информации не только о выходной величине (перемещении или угле поворота) , но и о ее производных (скорости и ускорении) дает возможность достаточно точно сформировать требуемую форму переходных процессов, т.е. создать систему с заданными динамическими показателями. Таким образом, по принципу построения системы управления следящие системы можно разделить на одноконтурные и многоконтурные.

Показатели качества следящих электроприводов

Основным показателем качества следящих систем является точность, с которой рабочий орган “следит” за изменением сигнала задания во всех режимах.

Точность оценивается разностью (ошибкой) d между заданным aз и действительным a значениями выходной координаты (угла или положения), т.е.

d= aз - a

Ошибки слежения являются следствием воздействия внутренних и внешних возмущений и задающего сигнала.

К внешним возмущающим воздействиям можно отнести момент статического сопротивления, колебания напряжения питающей сети, изменение температуры окружающей среды и др.

Внутренние возмущения определяются нестабильностью параметров элементов привода, погрешностью датчика положения, различного рода шумами и помехами в информационной подсистеме.

На рис. 8.2 изображена обобщенная структурная схема следящего электропривода, к которой могут быть приведены практически все реальные структурные схемы линеаризованных систем (в том числе импульсных и цифровых, если их можно представить эквивалентными непрерывными системами)

Для упрощения ограничимся одним наиболее существенным возмущающим воздействием - моментом статического сопротивления Мс. Здесь W1(p)- передаточная функция разомкнутой системы по каналу управления; Wм(p)- передаточная функция участка разомкнутой системы между возмущающим воздействием и выходом системы; d - ошибка регулирования.

В соответствии со структурной схемой общая ошибка регулирования содержит две составляющие: первая dз является результатом изменения задающего сигнала; вторая d м - зависит от возмущающего воздействия.

Для приведенной обобщенной структурной схемы ошибка определяется выражением

d(p)= dз (p) + dм (p) = [image] +

Из последнего выражения на основании теоремы о конечном значении функции определим установившуюся ошибку как

d уст= pd(p)½p=0=½p [image] ½ p=0 +½ p [image] ½ p=0

Исследование работы следящих систем производят, как правило, при следующих типовых задающих сигналах:

а. Скачкообразное изменение входного сигнала

aз(t)= a0 1(t), где a0 =const

б. Равномерная заводка

aз(t)= [image] t 1(t), где [image] - скорость задавания

в. Заводка с постоянным ускорением

aз(t)= [image] (t2/2) 1(t), где [image] - ускорение задавания

г. Синусоидальная заводка

aз(t)= aзm Sin W з t, где aзm , W з - соответственно амплитуда и угловая частота задающего сигнала.

2. Линейная математическая модель обобщенного следящего электропривода с П- регулятором положения . Оптимизация контура регулирования положения.

Структурная схема системы с П-регулятором угла (положения) представлена на рис. 8.3 ПИ- регуляторы момента и скорости представлены детализированными структурными схемами. Через Eps1 , Eps2 и Eps3 обозначены ошибки соответственно на входах контуров регулирования момента, скорости и угла. Выходное напряжение uзад(м) регулятора скорости является задающим для подчиненного контура регулирования момента. Выходное напряжение uрп регулятора угла является задающим для подчиненного контура регулирования скорости.

Математическая модель системы содержит 7 уравнений состояния

Tпр dw0/dt= - w0 +Kпр uу

Tэ [image] = bw0 - M- bw1,

JS [image] = M- Mc

= Eps1

= Eps 2,

= w1,

где к уравнениям состояния, характеризующим известную (см. лекцию 7) двухконтурную систему регулирования скорости, добавлено уравнение, связывающее скорость и угол порота двигателя. К известным уравнениям связей

Eps2 = uзад - Кw w1

Eps1 = Eps2 Кп2 - Км М+ yp2 (Кп2/Ти2)

uу= Eps1Кп1 +(Кп1/Ти1)yp1

нужно добавить уравнения

Eps3 = uзадa - Кa a

Uрп= Кп3 Eps3

Оптимизация системы регулирования угла

Оптимизация внутреннего контура регулирования момента осуществляется из условия обеспечения настройки на технический оптимум на основе соотношений, представленных в лекции 5. При оптимизации первого внешнего контура ( контура регулирования скорости ) замкнутый контур регулирования момента заменяется эквивалентным апериодическим звеном первого порядка с передаточной функцией

,

где Tm1- некомпенсированная постоянная времени контура. При безинерционном датчике момента эта постоянная времени определяется как Tm1= Тпр.

Настройка контура регулирования скорости на симметричный оптимум осуществляется на основе соотношений, представленных в лекции 7. При этом передаточная функция замкнутого контура регулирования скорости со сглаживающим фильтром на входе имеет вид

,

где Tm2- некомпенсированная постоянная времени контура. При безинерционном датчике скорости эта постоянная времени определяется как Tm2= 2 Tm1= 2 Тпр. При синтезе внешнего контура регулирования угла указанная передаточная функция упрощается следующим образом

.

Расчетная структурная схема подлежащего оптимизации контура регулирования угла представлена на рис.8.4, где aзад= Uзадa/Ka - заданное значение угла поворота следящей оси. Настройка контура на технический оптимум будет обеспечена при коэффициенте передачи П-регулятора угла, найденном из условия

.

Принимая Tm3 = 4 Tm2 , получим на основе приведенного условия

При таком выборе коэффициента передачи П-регулятора угла передаточная функция синтезированного контура может быть представлена в виде

или

8.3. Характеристики следящего электропривода с П-регулятором положения в типовых режимах работы

Система является астатической по отношению к задающему сигналу из-за наличия интегрирующего звена в прямой цепи. Приводя структурную схему данной системы к виду (рис.8.2), получим

Wм(p)= [image] .

Для обобщения рассуждений выделим в передаточной функции W1(p) безинерционные и интегрирующие звенья, т.е.

,

где

На рис.8.5,а представлены расчетные кривые переходных процессов при отработке скачка задающего воздействия в линейных контурах регулирования угла , скорости и момента при нулевых начальных условиях и нулевом моменте нагрузки на валу двигателя. Как видно, время переходного процесса определяется в конечном итоге величиной некомпенсированной постоянной времени внутреннего контура регулирования момента.

Установившаяся ошибка определяется выражением

dуст= ½p [image] ½ p=0 +½ p [image] ½ p=0

Первое слагаемое, определяющее составляющую статической ошибки от задающего сигнала равно нулю, в силу астатизма первого порядка системы.

Установившаяся ошибка, обусловленная постоянным статическим моментом нагрузки , равна 0, поскольку подчиненный контур регулирования скорости с ПИ- регулятором, обладает астатизмом первого порядка по возмущению. Поэтому далее , полагая статический момент нагрузки постоянным, будем анализировать только составляющие ошибки, обусловленные задающим воздействием.

Установившаяся ошибка системы в режиме равномерной заводки при aз(t)= [image] t 1(t) определяется выражением

dуст = ½p [image] ½ p=0 = [image] /Dw=dск

Как видно установившаяся ошибка, называемая скоростной, пропорциональна скорости задавания,.

dск = [image] / Dw

Коэффициент пропорциональности между скоростной ошибкой и скоростью задавания (равной скорости вращения следящего вала) называют добротностью системы по скорости Dw . Этот коэффициент численно равен коэффициенту передачи разомкнутой системы , т.е. в нашем случае

Dw =dск / [image] =Кп3 Кa/ Кw (1/c).

Поскольку, как было показано выше , при настройке внешнего контура на технический оптимум

, то

(1/c).

На рис.8.5,б представлены расчетные кривые процессов изменения угла , скорости и момента при нулевых начальных условиях и нулевом моменте нагрузки на валу двигателя в процессе отработки линейно- изменяющегося задания. В этом случае первоначально происходит постепенное нарастание ошибки , а затем имеет место установившееся движение с некоторой постоянной угловой ошибкой, определяемой добротностью системы по скорости.

Оценим далее установившуюся ошибку в режиме слежения за сигналом, меняющимся с постоянным ускорением. Эта ошибка определяется выражением

dуст= ½p [image] ½ p=0 =¥

Для рассматриваемой системы эта ошибка равна бесконечности, т.е. следящий привод с астатизмом первого порядка принципиально не может работать в режиме с постоянным ускорением из-за неограниченного возрастания ошибки d уст.

Режим гармонического задающего воздействия позволяет оценить в наиболее полной степени динамические свойства линейного следящего электропривода. При отсутствии момента нагрузки установившаяся ошибка в режиме синусоидальной заводки также изменяется по гармоническому закону с частотой W з , т.е.

d уст = dm Sin (W з t + y)

Точность системы в этом режиме оценивают по амплитуде ошибки dm , которую находят по формуле

dm = aзm / mod[1+W1(jW з)].

В области рабочих частот

1+W1(jw)@ W1(jW з)

и потому

dm = aзm / mod[W1(jW з)]= aзm /A(W з).

где A(W з)- значение амплитудно-частотной характеристики на частоте задавания ( или отношение амплитуды угла выходной оси am к амплитуде ошибки dm.

Для рассматриваемой системы амплитуда ошибки dm связана с амплитудой синусоидального am при условии что частота задавания частотой Wз существенно меньше частоты 1/ 2Тm3 , определяющей полосу пропускания контура и равной добротности контура следующим приближенным соотношением

aзm(Wз )/ dm (Wз )= mod[D/jW з]= D/W з,

поскольку разомкнутый контур подобен идеальному интегрирующему звену с коэффициентом передачи D. Следовательно,

dm£ aзmWз / D.

Как видно, при постоянной амплитуде сигнала задания амплитуда ошибки падает с ростом добротности контура по скорости и уменьшением частоты задавания относительно предельной частоты полосы пропускания системы 1/ 2Тm3.

Уменьшение погрешности следящей системы, построенной на основе подчиненного регулирования в основном может быть достигнуто двумя путями: повышение порядка астатизма основного контура ( положения) и использование принципа комбинированного управления.

Комбинированное управление предусматривает создание двух каналов: разомкнутого скоростного канала и замкнутого позиционного. Дополнительный скоростной канала с целью достижения минимальных ошибок при использовании структуры подчиненного регулирования целесообразно организовать в на основе блока вычисления скорости изменения задающего сигнала и подачи его выходного сигнала либо непосредственно на вход контура регулирования положения (как показана на рис. 8.2), либо на вход пропорционального регулятора положения. В обоих случаях выбором коэффициента К* можно свести скоростную ошибку к нулю не влияя динамические качества собственно контура регулирования положения. При способе реализации, представленном на рис. 8.3, для полной компенсации скоростной ошибки достаточно выполнить условие

К*=1/D= 2Tm3=8Tm2=16Tпр

На рис.8.5,в представлены расчетные кривые процессов кривые изменения угла , скорости и момента при нулевых начальных условиях и нулевом моменте нагрузки на валу двигателя в процессе отработки линейно- изменяющегося задания в системе с комбинированным управлением.

Вопросы к лекции 8

1. В чем преимущества и недостатки систем подчиненного регулирования угла или положения по сравнению с одноконтурными системами

2. Сколько контуров может содержать система подчиненного регулирования угла

3. Нарисуйте обобщенную структурную схему трехконтурной системы регулирования скорости

4. Какие элементы содержит вектор состояния трехконтурной системы регулирования угла с П-регулятором во внешнем контуре

5. Какие элементы содержит вектор управления трехконтурной системы регулирования скорости с П-регулятором во внешнем контуре

6. Запишите систему уравнения состояния трехконтурной системы регулирования скорости с П-регулятором во внешнем контуре в матричной форме

7. По какому критерию настраивается внутренний контур системы

8. По какому критерию настраивается контур регулирования скорости системы и какой регулятор он содержит

9. По каким критериям может настраиваться контур регулирования угла и какие регуляторы он содержит

10. Приведите оптимизированную систему с П-регулятором угла к расчетному виду, представленному на рис.8.2.

11. Назовите тестовые законы задавания

12. Какие составляющие содержит ошибка системы

13. Как зависит статическая ошибка оптимизированной системы от величины момента нагрузки на валу двигателя

14. Проанализируйте составляющие ошибки системы при постоянном моменте нагрузки и постоянном напряжении задания

15. Изобразите реакцию координат оптимизированной системы на скачок задающего воздействия D U зад при нулевых начальных условиях и ненулевом моменте нагрузки

16. Как соотносятся времена реакций оптимизированной системы на скачки задающего и возмущающего воздействий

17. Проанализируйте составляющие ошибки системы при постоянном моменте нагрузки и линейной заводке

18. Изобразите реакцию оптимизированной системы на линейно- изменяющееся входное воздействие при ненулевом моменте нагрузки

19. От чего зависит величина установившейся скоростной ошибки при линейной заводке. Что такое добротность системы по скорости и от чего она зависит

20. Как уменьшить скоростную ошибку не меняя динамических качеств замкнутого контура регулирования угла ( не меняя настроек регуляторов). Что такое комбинированное управление.

21. Как подсчитать оптимальный коэффициент К*

22. Проанализируйте составляющие ошибки системы при постоянном моменте нагрузки и синусоидальной заводке

23. Изобразите реакцию оптимизированной системы на синусоидальное входное воздействие

24. От чего зависит амплитуда ошибки при синусоидальной заводке. Как она связано с амплитудой и частотой заводки и с параметрами оптимизированной системы


1

Введение.
1.Обобщенная ЭМС и ее типовые звенья.
Уравнения и динамические свойства звеньев обобщенной ЭМС.
Структурная схема двигателя как обобщенной ЭМС.
Динамические свойства обобщенного двигателя.
2. Типовые алгоритмы управления и регуляторы
3. Понятие оптимизации.
Типовые критерии и приемы оптимизации
4. Системы регулирования момента
5. Одноконтурные системы регулирования скорости
6. Системы подчиненного регулирования скорости
7. Одноконтурные системы регулирования угла (положения)
8. Системы подчиненного регулирования угла (положения). Вопросы


Лекция 1

Введение

Электромеханической системой ЭМС мы будем называть электромеханическое устройство, содержащее управляемый электрический преобразователь УЭП, электромеханический преобразователь ЭМП, передаточный механизм ПМ, рабочий механизм (рабочий орган) РМ и устройство управления УУ. Структурная схема системы может быть представлена в следующем виде

ЭПС

»uc

uу УЭП ЭМП ПМ РМ

УУ (ИПС)

Подпись: от датч коорд.

Р

ИПУ

Подпись: Xзад

Рис.0.1

Электромеханический преобразователь (электрический двигатель) ЭМП преобразует электрическую энергию на выходе электрического преобразователя в механическую энергию на своем валу. Эта энергия через передаточный механизм ПМ, содержащий механические передачи и соединительные муфты, передается рабочему механизму РМ. В ряде случаев ПМ может отсутствовать (в безредукторных системах ) или входить конструктивно в состав рабочего механизма РМ.

Управляемый электрический преобразователь УЭП предназначен для управления потоком электрической энергии, поступающей из сети с целью регулирования режимов работы ЭМП. Управляющим воздействием является электрический сигнал Uу.

Управляющее устройство в ЭМС предназначено для обработки информации о задающих воздействиях и координатах состояния системы и выработки на ее основе сигнала управления преобразовательным устройством Uу с целью обеспечения желаемого характера изменения координат системы. В состав устройства управления входят измерительно-преобразовательные устройства ИПУ и регулятор Р. Выходные переменные силовой части системы и механизма измеряются и преобразуются в пропорциональные им электрические сигналы с помощью измерительно-преобразовательного устройства ИПУ. В его состав могут входить тахогенераторы, измерители положения, напряжения, тока, АЦП и ЦАП и т.п.

Основные узлы ЭПС-управляемый преобразователь электрической энергии УЭП, электромеханический преобразователь ЭМП, передаточное устройство ПУ и рабочий механизм РМ образуют энергетическую подсистему ЭПС.

Информационную подсистему ИПС образуют устройства управления УУ, а в ряде случаев и устройства диагностирования УД и защиты УЗ. Взаимосвязь информационных и энергетических подсистем обычно осуществляется по принципу обратной связи.

Рассматривая ЭМС как САУ выходной координатой, ее можно представить в виде простейшей структурной схемы

и выделить в ней объект управления ОУ и регулятор Р.

По ряду причин в качестве объекта управления мы будем рассматривать систему "УЭП-ЭМП-ПМ-РМ" или энергетическую подсистему ЭПС.

В простейшем случае объекты управления, характеризуемые вектором СОСТОЯНИЯ Y(t) имеют одну УПРАВЛЯЮЩУЮ переменную u(t), одну РЕГУЛИРУЕМУЮ координату X(t), и ВОЗМУЩАЮЩЕЕ возействие W(t). (см. схему на рис. 0.2 ) В более сложных случаях объект является многоканальным, с несколькими управляющими воздействиями, несколькими регулируемыми координатами и с взаимосвязанными каналами.

Проектирование систем управления осуществляется из условия реализации задач стабилизации, слежения и терминального управления.

- Задача стабилизации может быть сформулирована как задача поддержания выходной координаты ( или вектора выхода) на постоянном уровне., т.е. X=const. ЭМС, реализующие эту задачу , называют системами стабилизации выходного параметра ( момента на валу, скорости вращения или линейного перемещения вала РМ, угла поворота вала и т.п. );

- Задача слежения - выполнение условия X(t)= Xзад(t); Если закон изменения Xзад(t) заранее неизвестен- то такие системы называются следящими, если он заранее определен- то такие системы называют системами программного управления;

- Задача терминального управления предусматривает перемещение объекта управления из исходной (начальной) в заданную ( конечную) точку при соблюдени заданного критерия оптимизаци (минимального времени перемещения, минимальных затрат энергии и т.п.).

Управление, обеспечивающее решение рассмотренных локальных задач, осуществляется с помощью функциональных элементов САР, называемых регуляторами. Регулятор производит расчет управляющих сигналов u(t) на основании анализа текущих значений задающего воздействия, регулируемых координат и других сигналов, поступающих в устройство управления. Алгоритм расчета носит название алгоритма ( закона) управления. Структурные решения регуляторов САУ и законы управления, формируемые ими во многом определяются как характеристиками объектов, так и целями управления.

В зависимости от структуры контуров различают разомкнутое управление, управление по отклонению и комбинированное управление.

Если предположить, что ЭПС системы сформирована в соответствии с требованиями ТЗ на ЭМС, т.е. выбран по мощности ЭМП (электродвигатель) , определен его тип, выбран передаточный механизм , определены тип, мощность и структура управляемого электрического преобразователя, то процедура проектирования САУ включает следующие этапы:

1. Разработка математической модели ЭПС, как объекта управления.

2. Выбор алгоритма управления объектом и структуры САУ на основе модели объекта (ЭПС) .

3. Оптимизация параметров алгоритма (выбор настроек регуляторов) с использованием критериев оптимизации и правил настроек.

Основные трудности, возникающие при решении задач анализа и синтеза систем управления современных ЭМС связаны с нелинейными характеристиками и дискретным характером звеньев ЭПС.

Сложность процессов преобразования энергии в ЭПС, высокий порядок дифференциальных уравнений, их описывающих, их кусочно- линейный характер, большое число интервалов постоянства коэф-фициентов уравнений, дискретный характер процессов преобразования энергии в ЭПС и сигналов в каналах управления не позволяет решить задачу синтеза САУ в большинстве случаев строго и точно аналитическим путем.

Поэтому наиболее широко распространенным принципом проектирования САУ является проектирование по прототипу, заклю-чающееся в том, что на основании технического задания выбирается типовая структура системы управления и без ее существенного изменения определяются значения параметров ее управляющей части.

ЦЕЛЬЮ предлагаемого раздела дисциплины "Электромеханические и мехатронные системы" является изучение типовых структур обобщенных электромеханических систем, типовых алгоритмов управления, методов их оптимизации, вопросов математического моделирования линеаризованных структур ЭМС, общих вопросов регулирования момента, скорости и положения

ЛИТЕРАТУРА

1. В.И, Ключев. Теория электропривода. Энергоатомиздат, Москва, 2001 г.

2.С.А. Ковчин, Ю.А. Сабинин. Теория электропривода. Энергоатомиздат, С- Петербург, 1994 г.

3. А.В. Башарин, В.А. Новиков, Г.Г. Соколовский. Управление электроприводами. Энергоатомиздат, Ленинград, 1982 г.

4. Ю.А. Борцов, Г.Г. Соколовский. Автоматизированный электропривод с упругими связями . Энергоатомиздат, С-Петербург, 1992 г.


6