Введение

использование только непрерывных сигналов в системах регулирования и управления иногда оказывается нецелесообразным или даже технически невозможным. В этом случае применяются дискретные сигналы.

Дискретный сигнал - это такой сигнал, который представляется последовательностью значений а 0, а1, ... аN ...

Наиболее распространены следующие замены НП сигналов дискретными сигналами:

1.

Значение амплитуды импульса пропорционально сигналу: амплитудно- импульсная модуляция.

2.

ширина импульса пропорциональна амплитуде сигнала: широтно-импульсная модуляция.

3.

Величина смещения импульсов и их количество пропорциональны амплитуде сигнала: фазо-импульсная модуляция.

Во всех рассмотренных случаях импульсный сигнал несет в себе информацию о последовательности значений аN=f[nT].

4. Замена значений аN дискретными по уровню сигналам происходит при аналого-цифровом преобразовании.

Итак, сигналы могут быть дискретны по уровню и по времени.

Принимая во внимание способы получения дискретных сигналов можно ввести следующую классификацию:

· импульсная система - в которой используются сигналы, дискретные по времени.

· релейная система - сигналы, дискретные по уровню.

· цифровая система - дискретные как по времени так и по уровню.

Одной из основных проблем теории цифрового управления является способ описания непрерывной системы, связанной с ЭВМ посредством АЦ- и ЦА-преобразователей. Рассмотрим следующую систему:

Сигналы в ЭВМ представляют собой последовательности {u(tk)} и {y(tk)}; необходимо определить зависимости между ними.

Построение дискретного эквивалента непрерывной системы наз Квантованием непрерывной системы, Полученная в результате квантования модель называется стробоскопической, т.к. она дает связь между переменными системы только в моменты квантования.

В дальнейшем будем считать, что нп система задается следующими уравнениями состояния

(1)

Наиболее распространенная ситуация в цифровом управлении состоит в том, что АЦ-преобразователь сохраняет уровень аналогового сигнала постоянным до тех пор, пока не потребуются новое преобразование.

Определим связь между переменными системы в моменты квантования. При заданном состоянии в моменты квантования tk состояние в некоторый момент t можно получить, решив систему (1)

(2)

Тогда состояние системы в момент tk+1 определяется

tk+1-s==y s-->tk==>y-->tk+1-tk==T

-ds=dy==>s-->tk+1==>y-->0

Пусть АЦ_ и ЦА-преобразователи абсолютно синхронизированы и пусть время преобразования незначительно, то можно считать, что вход u и выход y квантуются в одни и те же моменты:

x(tk+1)=Ф(tk+1,tk) x(tk)+Г(tk+1,tk) u(tk) (3)

где Ф(tk+1,tk)=exp(AT), T=tk+1-tk (4)

Г(tk+1,tk)= [image] (5)

Т.о. связь между дискретными сигналами выражается разностными уравнениями (3). Уравнения (3) точные!! Модель (3) наз квантованием в приближении нулевого порядка системы (1).

Способы вычисления функций Ф и Г.

Ф=e(Ah), (6)

Г= [image] (7)

При квантовании непрерывной системы требуется вычислить матричную экспоненту и проинтегрировать ее. Это может быть осуществлено несколькими способами

- разложение матричной экспоненты в ряд

- преобразование Лапласа - преобразование Лапласа ехр(At) есть (sE-A)-1, где Е - единичная матрица

- использование теоремы Гамильтона-Кэли

- приведение к Жордановой форме.

Один из способов упрощения выкладок состоит в предварительном вычислении ф-ии:

Y= [image] (8)

Тогда Ф и Г можно записать как :

Ф=Е+AY; Г=YВ (9)

Примеры: Двойной интегратор

Тогда дискретная модель принимает вид

x(kh+h)= [image] .

Примеры. Электродвигатель.

Эл. Двигатель постоянного тока можно описать моделью (через передаточные функции):

Вход u - напряжение на обмотке возбуждения двигателя, а выход x2 - угол поворота двигателя

Нормализованная модель электромотора постоянного тока

Преобразование Лапласа дает:

Инверсия квантования

Квантование определяет отображение непрерывных систем типа (1) в дискретные типа (6). Простой пример показывает, что это отображение не всегда обратимо:

Пример:

Не существует ДУ первого порядка, которое после квантования приводило бы к разностному уравнению:

xk+1=-5xk+uk

Ф=eAh=-5; Г=1

Поскольку уравнение Ф== еah =-5 не имеет действительного решения, так как еah всегда больше нуля.

То модель (6) более общая, чем (1). Однако, если матрица Ф не имеет действительных отрицательных собственных значений, то существует соответствующая непрерывная система, получающаяся в результате решения (7) и (9) относительно А и В. Из (7) следует, что А=ln(Ф)/h=ln(Ф1/h), где ln(Ф) - матричная логарифмическая функция.

Уравнение (9) дает:

B=Y-1Г,

если система не содержит интеграторов, то (Ф-Е) не вырождена; (9)®

B=Y-1Г=(AY)-1АГ =(Ф-Е) -1 АГ

где Y - определяется из уравнения (8)

Пример. Гармонический осциллятор.

(*)

l2+b2=0®l1,2=±b i ® x1одн=C1sin b t + C2 cos b t

xч=А- const ® (*) ® x1= C1sin b t + C2 cos b t + u ®

x’1=C1b cos b t-C2b sin b t®

x2=C1cosb t-C2sinb t

x1=C1cos b t+C2cosb t+u

® t=0® x10=C2+u ; x20=C1

x2=x20cosb t-(x10-u)sinb t

x1=x20sinb t+(x10-u)cosb t+u

x1=x10cosb t+x20sinb t+(1-cosb t)u

x2=-x10sinb t+x20cosb t+sinb t

получено разностное уравнение. H - интервал квантования; b=µ+2p n/h, n=0, 1, ...


Решение уравнения состояния.

Дискретная стационарная система может быть описана разностными уравнениями:

х(к+1)=Фх(к)+Гu(к) (*)

(h=1 - для простоты).

Пусть известно х(0) и u(0): тогда (*) можно переписать:

х(1)=Фх(0)+Гu(0)

х(2)=Фх(1)+Гu(1)=Ф(Фх(0)+Гu(0)) Гu(1)=Ф2х0+ФГu0+Гu1®

Пример: Пусть процесс описывается дифференциальным уравнением:

d х/dt=-5x+5.

Получим разностное уравнение:

х’+5х=5; х=ходн+хчаст;® ходн=С×ехр(-5t); хчаст=А - const ®

0+5A=5 ® A=1 ®

x=C×exp(-5t)+1;

t=0 ® x0=C+1 ® C=x0-1 ®

x=(x0-1)exp(-5t)+1 ®

x=x0exp(-5t)+1-exp(-5t) ®

---------------------------------------------------------

Далее MATHCAD:

T:=0.001 ex:=e-5T; x0:=10

i:=0..100

xi+1:=xi ex - ex+1

Строим график (i, xi)

--------------------------------------------------------

Квантование систем с запаздыванием

Запаздывание по времени характерно для математических моделей производственных процессов.

Пусть система описывается уравнением:

(1)

Пусть t<h - период квантования. Интегрирование (1) дает:

(2)

Связь сигнала u(t) с задержанным сигналом u(t-t)

Т.к. u(t) -кусочно-постоянен в течение периода квантования, то сигнал u(t-t) также кусочно-постоянен. Однако запаздывающий й сигнал изменяется между моментами квантования. Сл-но интеграл нужно разбить на 2 участка

Т.о. в рез-те квантования непрерывной системы (1) получим:

x(kh+h)=Фx(kh)+Г0u(kh)+Г1u(kh-h) (3)

где

Ф=eAh,

(4)

(5)

Модель (3) в терминах управления состояния имеет вид:

Пример Двойной интегратор с запаздыванием

Ф=eAh=

x(kh+h)=

Преобразование моделей в пространстве состояний.

Итак, дискретная система м.б. описана моделью:

x(k+1)=Ф x(k)+Г u(k)

y(k)=Cx(k)+Du(k)

Как и в случае непрерывных систем можно ввести новые координаты.

Пусть Т - невырожденная матрица и определим новый вектор состояния: z(k)=Tx(k) ==>

z(k+1)=T Ф x(k)+TГu(k)=TФT-1z(k)+TГu(k)

y(k)=Cx(k)+Du(k)=CT-1z(k)+Du(k)

Теорема: Характеристическое уравнение det[Ф-l E]=0 является инвариантом (т.е. не меняется), если det(T)¹0.

Д-во

det(TФT-1-l TT-1)=det(T)×det(Ф-l E)×det(T-1)=det(Ф-l E)

Новые координаты могут вводиться для получения более простых форм уравнений:

Диагональная форма

Пусть l i - различны ==> что существует Т: det(T)¹0 и что:

li - собственные значения матрицы. В этом случае получается мн-во несвязанных разностных ур-ий первого порядка:

z1(k+1)=l1z1(k)+b1u(k)

....................

zn(k+1)=l nzn(k)+b nu(k)

Решить такую систему несложно:

zi(k+1)=l izi(k)+b iu(k) ==>

z(1)= l izi(0)+b iu(0)

z(2)= l izi(1)+b iu(1)=l(l z(0)+b iu(0)+b u(1)=

=l 2z(0)+lb u(0)+b u(1)

...

zi(k)=l ikzi(0)+

Наблюдаемая форма

Пусть характеристическое уравнение матрицы Ф имеет вид (det(Ф-l E)=0):

l n+a1l n-1+a2l n-2+...+an=0

и что матрица

не вырождена. Тогда существует такая матрица преобразования, что преобразованная система имеет вид:

который называется наблюдаемой канонической формой. Преимуществами этой формы являются простота нахождения модели вход-выход и определение подходящего наблюдателя.

Управляемая форма

Пусть характеристическое уравнение матрицы Ф :

l n+a1l n-1+a2l n-2+...+an=0

и пусть матрица [Г, ФГ, ... Фn-2Г, Фn-1Г] невырождена. Тогда существует T :

-управляемая каноническая форма. Ее преимущество заключается в простоте вычислений модели вход-выход и закона регулирования с обратной связью по состоянию.


Введение

Модели типа вход-выход.

Внутренние модели описывают все внутренние связи между переменными системы. Внешние модели выражают зависимость только между входом и выходом.

Покажем, что связь между входом и выходом для обычных линейных систем может быть выражена импульсной характеристикой.

Импульсная характеристика.

Рассмотрим дискретную одномерную систему. Входной и выходной сигналы в течении конечного интервала времени могут быть представлены векторами ограниченной размерности:

U=[u(t0)... u(tn-1)]T

Y=[y(t0)... y(tn-1)]T

Тогда общая модель , связывающая U и Y, имеет вид:

Y=HU+Yp

H -матрица (n*n), а вектор Yp - учитывает начальные условия.

Уравение для обычной линейной системы можно записать так:

(1)

yp(tk) введен для учета начальных условий.

Функция h(k,m) называется импульсной характеристикой, или весовой функцией системы. Эта функция очень удобна, так как ее легко непосредственно измерить:

для этого подать на вход системы единичный импульс шириной, равной интервалу квантования, и записать выходной сигнал. Для нулевых начальных условий значение импульсной характеристики h(k,m) есть реакция системы в момент tk на подачу на вход единичного импульсного сигнала в момент tm .

Для стационарных систем импульсная характеристика зависит только от разности k-m, т.е. h(k,m)=h(k-m).

Несложно вычислить импульсную характеристику системы , описанную моделью:

x(k+1)=Ф x(k)+Г u(k)

y(k)=Cx(k)

x(k0+1)=Ф x(k0)+Г u(k0)

x(k0+2)=Ф(Ф x(k0)+Г u(k0))+Г u(k0+1)=

=Ф2x(k 0)+ФГ u(k0)+Г u(k0+1)

...

или : k0+mº k

k 0+j º i

==>

Таким образом:

(2)

Теорема: Импульсная характеристика (2) инвариантна относительно преобразования координат.

Док-во:

Пусть z=Tx ==>

h(k)=C Ф k-1Г=(CT-1)(TФT-1)k-1TГ=

=CT-1TФk-1T-1TГ=CФk-1Г=h(k)

Оператор сдвига.

Введем следующий оператор “q”:

qf(k)=f(k+1)

q-1f(k)=f(k-1)

Операционное исчисление дает компактное описание систем и упрощает определение взаимосвязей между ее переменными: так как решение разностных уравнений сводится к чисто алгебраической задаче.

Оператор сдвига используется для упрощения работы с разностными уравнениями высокого порядка:

y(k+na)+a1y(k+na+1)+...+amy(k)=

=b0u(k+nb)+...+bnu(k) (3)

где na ³ nb.

Применение оператора сдвига дает:

(qna+a1qna-1+...+ana)y(k)=(b0qnb+...+bnb)u(k)

Вводя многочлены:

A(z)=zna+a1zna-1+...+ana

B(z)=b0znb+b1znb-1+...+bnb

Разностное уравнение можно записать в виде:

A(q)y(k)=B(q)u(k) (4)

Уравнение (4) также выражается через оператор обратного сдвига. Заметим, что (3) можно переписать иначе:

y(k)+a1y(k-1)+...+anay(k-na)=

=b0y(k+nb-na)+...+bnbu(k-na)=

=b0y(k-(na-nb))+...+bnbu(k-(na-nb)-nb)=

=b0y(k-d)+...+bnbu(k-d-nb)

где d=na-nb эксцесс полюсов системы.

Многочлен

A*(z)=1+a1z+a2z2+...anazna=znaA(z-1)

получается из A перестановкой коэффициентов в обратном порядке: он называется обратным многочленом. Тогда (3) можно записать:

A*(q-1)y(k)=B*(q-1)u(k-d) (5)

Импульсный передаточный оператор

Использование операционного исчисления позволяет выражать зависимость вход-выход как рациональную функцию от оператора прямого и обратного сдвига. Эту функцию называют импульсным передаточным оператором. Ее легко получить чисто алгебраическими преобразованиями любого описания системы, исключив внутренние переменные.

Рассмотрим модель:

x(kh+h)=Фx(kh)+Гu(kh)

y(kh)=Cx(kh)+Du(kh)

==>

x(k+1)=qx(k)=Ф x(k)+Г u(k) ==>

(qE-Ф)x(k)=Г u(k) ==>

y(k)=Cx(k)+Du(k)=[C(qE-Ф)-1Г+D]u(k) ==>

H(q)=C(qE-Ф)-1Г+D

Его можно выразить с помощью оператора обратного сдвига

H*(q-1)=C(E-q-1Ф)-1q-1Г+D

Для одномерной последовательности:

H(q)=C(qE-Ф)-1Г+D+B(q)/A(q) (8)

(8) == > что многочлен A является характеристическим многочленом матрицы Ф.

Следовательно модель вход-выход можно записать как

y(k)+a1y(k-1)+a2y(k-2)+...any(k-n)=

=b0u(k)+...+bnu(k-n)

В общем случае, в цифровых системах управления

b0=0.

Пример: Рассмотрим двойной интегратор при h=1.

было:

далее иы сосчитали (нашли):

Теперь пусть h=1

(8) ==>

Пример: Положим h=1 и введем временное запаздывание 0.5 с.

Было:

H(q)=C(qE-Ф)-1(Г0+Г1q-1)=

Пример. Рассмотрим систему, записанную в наблюдаемой канонической форме:

Импульсный передаточный оператор имеет вид:

Таким образом ai и bi в канонической форме определяют многочлены A и B соответственно. Это справедливо для n-мерных систем как в наблюдаемой, так и управляемой формах.

Теорема. Импульсный передаточный оператор H(q) модели в пространстве состояний не зависит от выбора пространства состояний.

Доказательство:

Дано: H(q)=C(qE-Ф)-1Г и z=Tx.

H=C(qE-Ф)-1Г=CT-1(qTT-1-TФT-1)-1TГ=

=СT-1(T(qE-Ф)T-1)-1TГ=

=CT-1T(qE-Ф)-1T-1TГ=C(qE-Ф)-1Г=H(q)

Полюса, нули и порядок системы.

Корни знаменателя в H(q) , т.е. характеристического многочлена, называются полюсами системы, Нули системы - это полюса обратной системы: они получаются из уравнения B(z)=0

Размерность пространства состояний или что то же самое, количество полюсов системы, определяют порядок системы.

Z-преобразование

- такое преобразование отображает полубесконечную последовательность дискретных значений на комплексную плоскость.

Определение. Рассмотрим дискретный сигнал {f(k): k=0, 1, 2...} Z-преобразование такого сигнала определяется соотношением

(Zf º) F(z)=

Обратное преобразование осуществляется по формуле

где контур интегрирования включает все полюса F(z)

СвойствоZ-преобразования

1. Определение: F(z)=

2. Обратное преобразование:

3. Линейность: Z(a f+b g)=a Zf+b Zg

4. Теорема о начальном значении:

5. Т-ма о конечном значении

Z-преобразование можно использовать для решения разностных уравнений:

xk+1=Ф xk+Гuk

yk=Cxk

Выполняем Z-преобразование для обеих частей:

Тогда можно ввести импульсную передаточную функцию вида

H(z)=(zE-Ф)-1

что идентично с импульсным оператором (см. оператор сдвига q) с заменой q на -z. Осуществляя обратное преобразование, получаем последовательность y(k).

Итак, рассмотрим непрерывную систему, описываемую n-мерной моделью в пространстве состояний:

dx/dt=Ax+Bu

y=C

Полюса системы - это собственные числа матрицы А, которые обычно обозначаются через l i(A) i=1, 2... n.

Квантование в приближении нулевого порядка дает дискретную систему:

x(kh+h)=Ф x(kh)+Г u(kh)

y(kh)=Cx(kh)

полюсами которой являются собственные значения матрицы Ф: l i(Ф) i=1, 2... n.

Так как Ф=ехр(Аh), то из свойства матричной функции следует, что:

-это уравнение задает отображение полюсов непрерывной системы в полюса дискретной системы. Однако такое отображение не является взаимно однозначным


Дискретное управление в линейных стационарных системах

Пусть управляемая система задана уравнениями:

dx/dt=Ax+bu (1)

(2)

k=enter(t/T), T>0, 0£ t £ T (3)

(4)

где А - постоянная n*n матрица; n - натуральное число (порядок непрерывной системы);

x - вектор фазового состояния;

b - постоянный вектор;

u - дискретное управление;

Т - период замыкания;

t - задержка управления;

m - число измеряемых координат (1£ m £ n);

ri - номер измеряемой координаты, i=1, 2, ... m;

- ri координата вектора х, измеренная в момент времени t=(k-j)T, j=0, 1, 2, ... s;

uk-1-j - значение управляющего сигнала, вычисленного в моменты времени t=(k-1-j)T;

j=0, 1, 2, ... s; s - число используемых прошлых значений;

- коэффициент в управлении при ri, измеренной j периодов до текущего дискретного состояния;

- коэффициент в управлении при самом управляющем сигнале, измеренном j+1 периодов тому назад.

Поставим две задачи:

1. При заданных значениях A, b, T, t, ri, m определить s и коэффициенты [image] , i=1, 2, ... m, j=0, 1, 2, ... s, так, чтобы характеристический многочлен замкнутой разностной системы совпадал с наперед заданным;

2. При заданных A, b, T, t, ri, m, s, [image] - найти характеристический многочлен замкнутой разностной системы.

Пусть t =0. Положим xk=x(kT) и проинтегрируем систему (1) на интервале [kT, (k+1)T]. Учитывая, что на этом интервале значение uk постоянно, получим:

(5)

Вычисляя постоянную матрицу AT=eAT, равную фундаментальной матрице однородной части системы (1) в точке t=T и постоянный вектор

равный значению частного решения неоднородной системы

dx/dt=Ax+b

в точке t=T (при нулевых начальных условиях), получим для xk систему разностных уравнений

xk+1=ATxk+bTuk (6)

решение которой xk при x0=x(0) совпадает со значениями решения x(kT) системы (1).

Пусть теперь t¹ 0. Положим [image] и проинтегрируем систему (1) на интервалах [kT, kT+t] и [kT+t, (k+1)T]. Получим:

Введем векторы:

bt= [image] , bT=

В результате получим разностную систему:

xk+1=ATxk+btuk-1 +bTuk (7)

Будем интерпретировать значение uk-1 как (n+1)-ю координату расширенного вектора [image] и присоединим к (7) разностное уравнение

Тогда получим разностную систему

xk+1=ATxk+btuk-1 +bTuk

(8)

порядка n+1, учитывающую задержку управляющего сигнала. Обозначим матрицу коэффициентов системы (8) через А*T, вектор при управлении через [image] . Получим

[i,j]=A T[i,j] для i, j=1, 2, ... n

[n+1,j]=0 для j=1, 2, ... n+1

[n+1,j]= bt

[i]= bT[i] для i=1, 2, ... n

[n+1]=1

Таким образом, случай с задержкой управления формально сводится к случаю без задержки путем повышения на единицу порядка разностной системы и введением [image] и [image] вместо AT и bT.

Определение 1. Разностная система (6) называется вполне управляемой, если векторы (bT, AT bT, ... bT) линейно независимы.

Определение 2. Система (1) с управлением (2) называется вполне управляемой, если вполне управляема система (6).

Будем рассматривать разностную систему вида (6) и вместо (4) полагать

(9)

допуская в случае, когда t > 0, значения [image] из (8).

Предположим, что система (6) вполне управляема. Тогда матрица

Q= [image] неособая. Тогда по построению Q обладает свойством:

Q`A`T(Q`)-1=LT, где LT - первая каноническая форма матрицы AT (` - означает транспонирование). И существует преобразование yk=Pxk такое, что

PATP-1=LT и PbT=hT, где h`T=(1, 0, ... 0).

Делая замену переменных

yk=Pxk (10)

получим разностную систему вида

yk= LT yk + hTuk (11)

Рассмотрим подробнее структуру полученной системы.

Пусть [image] , [image] . Введем обозначения

xk= xk[ ], yk= yk[ ], LT= LT[ ], P=P[ ].

Тогда из (10) получим:

(12)

где

Подставляя (12) в (9) перепишем (11) покомпонентно:

(13)

Повышая размерность вектора yk[ ] до n+s введением координат [image] , [image] , ... и дополняя систему (13) уравнениями

Получим однородную систему порядка n+s с матрицей такой же структуры как и LT. Принимая во внимание равенства

,

первое уравнение системы (13) можно переписать

Приводя подобные члены и считая -al коэффициентами при yk[l], получим

(14)

Уравнения (14) устанавливают связь между коэффициентами [image] управления (9) и коэффициентами al характеристического многочлена разностной системы. Таким образом, формулы (14) определяют решение второй из поставленных задач. Так как число коэффициентов al равно n+s, а число параметров [image] равно m*(s+1), то для решения первой задачи необходимо чтобы число s удовлетворяло неравенству:

m*(s+1) ³ n+s (15)

(s ³ (n-m)/(m-1))

Поскольку характеристический многочлен замкнутой разностной системы при управлении (9) определяется однозначно, то для решения первой задачи получаем следующее утверждение:

Пусть система (1) вполне управляема и число s - удовлетворяет неравенству (15). Для того чтобы при заданных числах al, l=1, 2, ... n+s, при заданном числе измеряемых координат m и заданных их номерах ri существовали числа [image] из (9), удовлетворяющие (14), необходимо и достаточно, чтобы система линейных уравнений (14) была разрешима относительно [image] .

Заметим, что первое целое число, большее или равное (n-m)/(m-1) есть наименьшее значение s, удовлетворяющее (15). Если m=1, то (15) справедливо только при n=1.

Рассмотрим особо случай, когда m=1, n>m. В этом случае не существует конечного значения s, удовлетворяющего (15). Другими словами, при измерении только одной из координат вектора xk в дискретные моменты времени, использование любого числа ее прошлых значений недостаточно для управления характеристическим многочленом разностной системы. С другой стороны в случае разрешимости уравнений (14), для этой цели достаточно условия m ³ 2. В связи с этим при m=1 в качестве второй измеряемой координаты можно использовать значения управляющего сигнала удовлетворяющего разностным уравнениям (8), которые тем самым приобретают смысл и при t=0. В этом случае, также как в случае t>0, в качестве исходных берутся значения AT0, bT0 вместо AT и bT и, кроме того, формально полагается m=2 и r2=n+1.

Так как переходные процессы в разностной системе затухают тем быстрее, чем меньше модули корней характеристического уравнения системы, то максимальная скорость затухания будет в случае, когда все корни равны нулю.

Определение: Управление вида (9) для системы (1) называется быстродействующим, если все корни характеристического многочлена матрицы, соответствующей замкнутой разностной системы равны нулю.

Тогда матрица системы (13), расширенной до порядка n+s, имеет вид:

Следовательно, Ln+s=0. Отсюда, учитывая, что yk=Lky0 для k=1, 2, 3... при любом начальном состоянии y0, заключаем, что переходные процессы при быстродействующем управлении имеют длительность не более n+s периодов Т.

Переходные процессы в системе (13) (соответственно в системе (1)) имеют минимальную длительность в том и только в том случае, когда управление (9) быстродействующее и m=n.

Действительно, при m=n из (15) заключаем, что достаточно положить s=0. Заметим также, что в случае m=n имеем l £ n, j=0. Следовательно, в этом случае система (14) всегда разрешима относительно [image] .

Пример 1.

Рассматривается следующая схема

C читая u постоянным управляющим воздействием на шаге h, получим следующее решение:

Потребуем чтобы yk+1 было равным yзад , тогда:

Полученное управление за один шаг переводит систему из любого начального состояния к yзад.

Пример 2.

Пусть объект описывается системой дифференциальных уравнений:

x1’=-952.38 x1+952.38 u

x2’=9091 x1-1908 x2

При этом измеряется только вторая координата. Управление принимает вид:

uk+1=-27.03 x2 k+14.079 x2 k-1 - 0.671uk

Рисунок переходного процесса при единичных начальных условиях:

Пример 3.

Тот же объект, но измеряются две координаты. Управление имeет вид:

uk+1=-14.773 x1 k -9.99 x2 k


Восстановление системы по наблюдаемым значениям выходного сигнала

Пусть наблюдаемый сигнал x(t) может быть представлен решением ДУ n-го порядка с постоянными коэффициентами. Тогда его наблюдаемые с периодом T>0 значения xk=x(kT) должны удовлетворять разностному уравнению n-го порядка вида:

xk+n+1+a1xk+n+a2xk+n-1+...+anxk+1=0 (1)

где ai, i=1, 2, ... n- неизвестные постоянные коэффициенты. Порядок n уравнения заранее так же не известен.

Положим в (1) k=n-1,n-2, ...,0. Тогда из (1) получим следующую линейную алгебраическую систему относительно неизвестных ai, i=1, 2, ... n

x2n=-a1x2n-1-a2x2n-2-...-anxn

x2n-1=-a1x2n-2-a2x2n-3-...-anxn-1 (2)

...

xn+1=-a1xn-a2xn-1-...-anx1

Матрица этой системы и вектор правых частей (3)

(3)

составлены из наблюденных значений сигнала и, следовательно, известны. Решая систему (2) относительно ai , можно найти разностное уравнение (1), которому удовлетворяют наблюденные значения сигнала.

При решении системы (1), естественно возникает вопрос о ее разрешимости. Поскольку n заранее неизвестно, то можно идти двумя путями:

1) начиная с n=1, увеличивать на единицу до тех пор, пока столбцы матриц и вектор в (3) не станут линейно зависимы. Если сигнал является решением некоторого ду, то соответствующее n найдется. Это значение определит порядок ур-я (1), а решение системы (2) - искомое разностное уравнение.

2) Задавая априорно некоторое n=N в качестве ожидаемого порядка разностного ур-я (N можно трактовать как желаемый порядок апроксимации); уменьшать на единицу в случае исходной линейной зависимости в (3) до получения линейной независимости.

Экстраполяция сигнала в точках, кратных периоду наблюдения

Пусть разностное ур-е восттановлено. Перепишем его в виде:

xk+n+1=-a1xk+n -a2xk+n-1-...-anxk+1 k=0, 1, 2, (1)

Подставляя в эту формулу n последних наблюденных значений x2n, x2n-1, ...xn+1 получим следующее (ненаблюденное) значение x2n+1, через период T.

Используя вычисляемые новые значения, можно также вычислять значения сигнала в другие моменты времени, кратные T.

Интерполяция сигнала.

(Алгоритм восстановления общего решения ду, проходящего через наблюденные точки).

Пусть восстановлено разностное уравнение (1). Рассмотрим его характеристический многочлен:

l n+a1l n-1+...+an-1l+an=0 (5)

Пусть zi, i=1,2... n - набор его корней в комплексной форме. В общем случае среди них могут быть кратные.

Пусть с учетом кратности корни распределены по m группам , отвечающим m различным корням, среди которых mr - вещественных и m-mr комплексных. Обозначим кратности корней через ki , i=1, 2, ... m. Пусть существует ду n-го порядка вида

y(n)+b1y(n-1)+b2y(n-2)+... +bn-1y(1) +bny=0 (6)

общее решение которого проходит через наблюденные значения сигнала. Тогда это решение может быть получено из общего решения (6) при надлежащем выборе произвольных постоянных. При принятых обозначениях это общее решение имеет следующую структуру:

(7)

При этом:

для вещественных zi > 0 и [image] (8)

для комплексных zi.

Так как начальные условия, необходимые для определения произвольных постоянных

(9)

неизвестны, то воспользуемся известными наблюденными значениями сигнала.

Для нахождения n постоянных (9) потребуется соответственно n наблюденных значений. Т.о. получаем следующую линейную относительно (9) алгебраическую систему уравнений:

y(kT)=xk

В случаях, когда определитель этой системы отличен от нуля, ее решение определяют значения (9). Подставляя эти значения в (7), получим формулу для вычисления значения сигнала в любой момент времени. Эта же формула мб использована для нахождения производных от наблюдаемого дискретного сигнала.

В случае, если ур-е (5) имеет n-кратный вещественный корень, равный единице, формула (7) становится алгебраическим многочленом.

В этом случае хар-кий многочлен(5) должен представляться в виде:

-биномиальные коэфф-ты, т.к. левая часть есть разложение бинома (l-1)n.

Апроксимация тригонометрическими многочленами так же является крайне частным случаем общей формулы (7).

Итак, (7) - представляет одинаковым образом сигналы периодические, апериодические и смешаные.


8


1